cannot RDP from windows 11

Hriday Saha 46 Reputation points
2023-11-20T05:41:48.9933333+00:00

we have some windows os11 device in environment. A few days back we noticed that for some server user cannot do RDP from windows 11 os. I found several articles mentioned that after specific windows update this issue occurred due to RDP try to be established with UDP protocol rather than TCP. But in our infrastructure only TCP is allowed to do RDP.

However, I tried to disable UDP protocol by registry value change, local group policy, change the location of mstsc.exe to a different location to resolve the issue. But none of this step resolve this problem.

Did Microsoft Release any update to fix the issue?

Status:
1.User cannot do RDP from windows 11 but can from windows 10 machine.
2. in windows 11 os inbound RDP is working fine.
3. for RDP we are using customize port for RDP.

Error: An internal error has occurred
Error code: 0x4

Extended error code:0x0

Tried Solution:

  1. Change the registry value to disable the UDP.

2.Configure local policy to disable the UDP.

  1. Change the mstsc.exe file in a different location and tried.

Current status: Same as it is.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,595 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,926 questions
0 comments No comments
{count} votes