Outlook can't update any emails because OST file reach the maximun size.

王楷朴 (Cooper Wang) 0 Reputation points
2023-11-22T07:31:37.36+00:00

I used to face the same issue, then I increased the mailbox size to solve this issue temporarily. But now it happens again. I do the below search, I noted that there is a InplaceHolds, I do the below things but it doesn't work. Can someone let me know how to remove the deleted items completely?

  1. Removed all of the related compliance search (I used to create a compliance search to delete a lot of emails)
  2. Use the MAPI tool to clear the Recoverable Items in Deleted folder
  3. Set mailbox "RetainDeletedItemsFor" to "0" and wait for many days
  4. Remove all of the "In-Place Hold" and run Start-ManagedFolderAssistant but it still appears in Get-Mailbox | select InPlaceHolds

Get-Mailbox -Identity xxxx | Format-List RecoverableItems,LitigationHoldEnabled,InPlaceHolds*

RecoverableItemsQuota : 50 GB (53,687,091,200 bytes)

RecoverableItemsWarningQuota : 45 GB (48,318,382,080 bytes)

LitigationHoldEnabled : False

InPlaceHolds : {0c1acec2daea475999de6ce7537a369b}


Get-MailboxStatistics xxxx | fl totaldeleteditemsize,totalitemsize

TotalDeletedItemSize : 30.64 GB (32,897,395,543 bytes)

TotalItemSize : 40.67 GB (43,666,392,132 bytes)


Get-MailboxFolderStatistics -Identity xxxx -FolderScope RecoverableItems |Format-Table Name,FolderAndSubfolderSize,ItemsInFolderAndSubfolders -Auto

Name FolderAndSubfolderSize ItemsInFolderAndSubfolders Recoverable Items 30.64 GB (32,903,561,002 bytes) 200612

Audits 0 B (0 bytes) 0

Calendar Logging 1.478 MB (1,549,816 bytes) 155

Deletions 0 B (0 bytes) 0

DiscoveryHolds 30.64 GB (32,902,011,186 bytes) 200457

Purges 0 B (0 bytes) 0

Versions 0 B (0 bytes) 0


Get-Mailbox wangkaipu | fl hold

LitigationHoldEnabled : False

RetentionHoldEnabled : False

EndDateForRetentionHold :

StartDateForRetentionHold :

LitigationHoldDate :

LitigationHoldOwner :

ComplianceTagHoldApplied : False

DelayHoldApplied : False

LitigationHoldDuration : Unlimited

SCLDeleteThreshold :

SCLRejectThreshold :

SCLQuarantineThreshold :

SCLJunkThreshold :

InPlaceHolds : {0c1acec2daea475999de6ce7537a369b}

Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
1,190 questions
Outlook
Outlook
A family of Microsoft email and calendar products.
3,416 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Jarvis Sun-MSFT 10,181 Reputation points Microsoft Vendor
    2023-11-23T07:06:02.74+00:00

    Hi @王楷朴 (Cooper Wang),

    Welcome to our Q&A forum!

    According to your description and steps, it seems that you haven't removed InPlaceHolds completely, the InPlaceHoldEnabled parameter should set to $false in the Exchange Management Shell. You can run below cmdlets to disables In-Place Hold and then removes the mailbox search. Then confirm again.

    Set-MailboxSearch "{0c1acec2daea475999de6ce7537a369b}" -InPlaceHoldEnabled $false; Remove-MailboxSearch "{0c1acec2daea475999de6ce7537a369b}"
    

    Reference: https://learn.microsoft.com/en-us/exchange/policy-and-compliance/holds/in-place-holds?view=exchserver-2019#remove-an-in-place-hold

    Please let us know if there are any updates.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.