Taskbar not showing on all screens.

Mitchell Walker 5 Reputation points
2023-11-23T01:58:09.96+00:00

I'm trying to get my taskbar to display across 3 screens while using Nvidia Surround.

Currently I'm running 7680 x 1440. My taskbar USE to span all 3 screens with no issues. A reset one day and now it's impossible.

I go into my taskbar settings and the slider to set "Show taskbar on all displays" is greyed out.

I've tried every suggestion I can find online from changing things in gpedit, to settings in registry editor... I simply can't seem to find a solution at all.

I've also understand this isn't the correct website to ask, however I tried asking this on answers.microsoft.com, and run into an error when trying to post, making it impossible until someone from within microsoft sorts out whatever the issue is on their end. I've already asked for solutions here https://learn.microsoft.com/en-us/answers/questions/1410133/cant-ask-question-on-answers-microsoft-com

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
11,125 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Wesley Li 6,360 Reputation points
    2023-12-25T07:33:20.2466667+00:00

    Hello

    I understand that you’re having trouble getting your taskbar to display across all 3 screens while using Nvidia Surround. Here are a few suggestions that might help:

    NVIDIA Control Panel Settings: Open the NVIDIA Control Panel and navigate to Desktop > Surround Displays. Uncheck “Confine Taskbar to Single Display” and check "Maximize Windows Across All Displays".

    Registry Editor: If the above step doesn’t work, you can try editing the registry. Navigate to the following paths in the Registry Editor:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Explorer

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Explorer

    Look for “TaskbarNoMultimon” on the right pane. If it exists, right-click and delete it. If it doesn’t exist, you can try creating the “Explorer” key, and in this, create the “TaskbarNoMultimon” DWORD, with value "0". Please remember to create a system restore point before editing the registry.

    Set Main Display: Make the center monitor the main display. Go to Settings > System > Display, select the center monitor from the boxes at the top under multiple displays, and check the “make this my main display” box.

    0 comments No comments