Approval requests are still stuck as Pending even after approved from Approver in MIM Portal.

Deepak Singh 40 Reputation points
2023-11-23T09:20:43.0133333+00:00

Hello everyone!

We stuck on issue, where we have normal situation for "Owner Approval" based group membership allocation.

As End user requests to get group's membership from MIM Portal, it sent request for approval to assigned Owners of the same group. Now, As any member from Owner's field go to "Approve Request" section in MIM Portal, requests are visible in queue for their response.

Once Owner select the particular request and select option to approve the same request, after submission of form such requests getting invisible from their "Approve Request" queue screen.

After this, When requestor went to manage my request option within MIM Portal, status of request is still showing as stuck in Authorizing status, when opening the same request it will show the approval object along with "Pending" status.

here, when MIM Admin try to look the the properties of same requests, open the approval object binded with the request, once it is opened, it is showing the Decision value as "Approved" along with Approver's reference (who approved the request), that is ApprovalResponse type object with completed status.

here, ideally, as soon as approvalResponse object got generated with Decision as "Approved", request should be able to proceed to mark associated Approval's status as "Approved" and associated request as "Completed" along with processing the request further, like notify notifications, assigning group membership to the requestor etc.

That is something not happening, and request is got stuck on "Authorizing " state only.

Kindly assist us here what all could be the possible reasons for impacting the normal process to complete the approval workflows to get this completed.

Thanks!!

Deepak Singh.

Microsoft Identity Manager
Microsoft Identity Manager
A family of Microsoft products that manage a user's digital identity using identity synchronization, certificate management, and user provisioning.
661 questions
0 comments No comments
{count} votes

Accepted answer
  1. Srinivas Rao Gorantla 80 Reputation points
    2023-11-23T12:18:40.5866667+00:00

    Hi Deepak,

    We do have to look into the Config file in Service folder and do necessary changes on the mail server section as below :

    <appSettings>
    <!-- Setup adds entries -->
    <add key="mailServer" value="mailserver Name" />
    <add key="isExchange" value="1" /> (value should be 1 instead of 0)
    <add key="synchronizationServerName" value="Sync Server Name" />
    <add key="sendAsAddress" value="Service Email Address" /> (which should be mail enabled which was used at the time of MIM Service and Portal Setup)
    </appSettings>

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful