cannot Disable security defaults.. save button greyed out

Andre Brouwer 0 Reputation points
2023-11-29T17:46:21.5866667+00:00

hi, I am a "global Administrator" of a M365 domain with a few users. im trying to disable the Security defaults for this domain in Entra but for some reason i cannot save the setting "disabled" the save button is greyed out

what am i doing wrong here? i do not want to use MS Authenticator and MFA for several reasons and simply want to disable it completely.. but i cannot SAVE the settings due to it being greyed out.. Global admins should have access to these settings ?

Andre

Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
6,059 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,497 questions
{count} votes

1 answer

Sort by: Most helpful
  1. James Hamil 22,986 Reputation points Microsoft Employee
    2023-11-29T23:15:23.1266667+00:00

    Hi @Andre Brouwer , if the "Save" button is greyed out when you try to disable Security Defaults in Azure AD, it's likely because there are some required settings that have not been configured yet. Here are a few things you can check:

    1. Make sure that all the required settings have been configured. To disable Security Defaults, you need to configure the following settings:
      • All users must have a valid mobile phone number in their profile.
      • All users must have a valid alternative email address in their profile.
      • All users must be enrolled in Azure AD Multi-Factor Authentication (MFA).
      • If any of these settings are missing or incomplete, the "Save" button will be greyed out.
    2. Check if there are any conditional access policies that require MFA. If there are any conditional access policies that require MFA, you will not be able to disable Security Defaults until those policies are updated.
    3. Make sure that you have the necessary permissions to modify the Security Defaults settings. As a global administrator, you should have the necessary permissions, but it's possible that your permissions have been restricted by another administrator.

    Please let me know if you have any questions and I can help you further.

    If this answer helps you please mark "Accept Answer" so other users can reference it.

    Thank you,

    James

    0 comments No comments