Unable to remove vnet with serviceAssociationLinks.

Shaker Gilbert 0 Reputation points
2023-12-04T15:26:02.5333333+00:00

I have applied a delegation of GitHub.Network/networkSettings to a vnet, upon removal of the resource group along with all of the objects, the delete fails. Apparently when applying the delegation, it sets allowDelete:false. I have tried to remove the association and even tried to remove everything one-by-one. Any attempt to remove the sal fails and removal of the vnet fails. I read in this forum it can be removed on the backend... I would also like to know if there is a way to alter the property so it can be deleted in the future?

  "serviceAssociationLinks": [
    {
      "allowDelete": false,
Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,289 questions
Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,339 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Shaker Gilbert 0 Reputation points
    2023-12-04T20:00:20.4033333+00:00

    My problem turns out to be resource cache out-of-sync issue. It's been resolved.