[KioskMode] Windows 11 Kiosk XML Configuration does not disable TaskBar

Dylan 5 Reputation points
2023-12-05T08:58:41.12+00:00

Dear Microsoft community,

I've been trying to setup a machine (Dell Inspiron 17) running Windows 11 Pro 10.0.22631 for a local user with a multi-app kiosk profile.

The requirement is simple: Upon login, the user shall only have access to cmd.exe (no desktop, no taskbar, no notification, no explorer.exe).

In addition to some GroupPolicy applied to the specific "TestKiosk1" user, I'm using the following Powershell code, including the Kiosk XML configuration.

cmd.exe does appear correctly and most of the actions are blocked but it seems that the ShowTaskBar has no effect whether it is true or false.

What am I missing in the configuration below to make this taskbar disabled?

<?xml version="1.0" encoding="utf-8" ?>
<AssignedAccessConfiguration 
    xmlns="http://schemas.microsoft.com/AssignedAccess/2017/config"
    xmlns:rs5="http://schemas.microsoft.com/AssignedAccess/201810/config"
    >
    <Profiles>
        <Profile Id="{5B328104-BD89-4863-AB27-4ED6EE355485}">
            <AllAppsList>
                <AllowedApps>
                    <App DesktopAppPath="%SystemRoot%\system32\cmd.exe" rs5:AutoLaunch="true"/>
                </AllowedApps>
            </AllAppsList>
            <Taskbar ShowTaskbar="false"/>
        </Profile>
    </Profiles>
    <Configs>
        <Config>
            <Account>TestKiosk1</Account>
            <DefaultProfile Id="{5B328104-BD89-4863-AB27-4ED6EE355485}"/>
        </Config>
    </Configs>
</AssignedAccessConfiguration>

Thank you for your support

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,941 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. boardmisha 0 Reputation points
    2024-02-23T13:03:02.49+00:00

    Hi, I have the same problem. I've configured a restricted access profile on a Windows Pro 11 machine through the MDM bridge and the the AssignedAccess configuration got applied. However, despite setting <Taskbar ShowTaskbar="false"/> the taskbar is displayed. Is this a bug on Win 11? Thanks!

    0 comments No comments