Error when trying to see the repositories for the Container Registry

Jan-Jaap Spies 0 Reputation points
2023-12-05T14:55:14.2533333+00:00

The AZ-400 lab described on https://microsoftlearning.github.io/AZ400-DesigningandImplementingMicrosoftDevOpsSolutions/Instructions/Labs/AZ400_M03_L06_Deploying_Docker_containers_to_Azure_App_Service_web_apps.html has a problem.

If I try to see the repositories in the Azure portal according to step 10 under exercise 2, Task 1, I get a "Unable to load information to the grid. Reason: {0}." Apparently, this has to do with permissions. With the workaround here, I got this to work: [https://learn.microsoft.com/en-us/answers/questions/1434566/unable-to-load-information-to-the-grid-reason-((0)](https://learn.microsoft.com/en-us/answers/questions/1434566/unable-to-load-information-to-the-grid-reason-((0))

But I don't think you want beginners to find this out for themselves, so please update the documentation.

(This lab is offered here in the learning path: https://learn.microsoft.com/en-us/training/modules/design-container-build-strategy/8-deploy-docker-containers-to-azure-app-service-web-apps )

Azure Training
Azure Training
Azure: A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.Training: Instruction to develop new skills.
1,304 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.

    1 deleted comment

    Comments have been turned off. Learn more

  2. Jan-Jaap Spies 0 Reputation points
    2023-12-05T16:36:25.9+00:00

    This is quite strange, considering the modules explicitly refer the user to Q & A:

    "For issues related to this module, post on Microsoft Q&A and use the #azure training tag." (Quoted from:

    https://learn.microsoft.com/en-us/training/modules/design-container-build-strategy/8-deploy-docker-containers-to-azure-app-service-web-apps )

    This cannot be a mistake, as Microsoft Q&A indeed feature an #Azure training tag.

    The reference to the exam pages doesn't make any sense, as this has nothing to do with the topics discussed there.

    0 comments No comments

  3. Srinud 2,040 Reputation points Microsoft Vendor
    2023-12-05T17:02:44.6966667+00:00

    Hi Jan-Jaap Spies,

    Thank for reaching out to us on the Q&A forum.

    We understand that you are facing this issue "Unable to load information to the grid. Reason: {0}" in the AZ-400 learn path.

    Please try and setup a Container Registry in a new Free subscription for training.

    If the default access to the Container Registry was Service Administrator change it to Owner (under Access Control IAM), once this is done you should be able to see the repository.

    Please don't hesitate to reach out to us if the issue persists.

    Please Accept the answer if you have found this helpful so that it is helpful for others in the community.