question

EricShen-4295 avatar image
0 Votes"
EricShen-4295 asked DerryRedwine-8159 answered

How to get Chrome to stop prompting for credentials when trying to start an SharePoint hosted app on an on-premise server

I am working with a client that has an on-premise SharePoint server (SharePoint 2019). The client's site has SharePoint hosted-apps which can be run successfully in Internet Explorer. However when I try to launch it in Chrome in a Remote Desktop session, I keep getting prompted for my login information. I am able to open the app from my computer using Chrome. I have also have other clients with an on-premise server where I am able to use Chrome to open the app inside a Remote Desktop session.

The URLs for the SharePoint site and the site not-secure (http).

I compared the Chrome and Internet Option settings between this client and the client without any problems and they are both identical.
Is there some setting in the Remote Desktop that I need to check?

office-sharepoint-server-administrationoffice-sharepoint-server-development
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @EricShen-4295 ,
Is there any update ? Did you try the suggestion below ?

0 Votes 0 ·
scogordo-2057 avatar image
0 Votes"
scogordo-2057 answered

Is the URL added to Trusted Sites in Chrome? If so, maybe there's a different GPO applied to each that's superseding?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Jerryzy avatar image
0 Votes"
Jerryzy answered trevorseward commented

Hi @EricShen-4295,

As the SharePoint hosted app can be accessed using IE and Cghrome in other clients, I assume this is a specific issue for the Chrome browser in the On-Premise Server.

Here are some suggestions for your referecen:

  1. I suggest you could try to clear up the Chrome cache and run in Private Mode to see if login can be successful.

  2. Try to disable Loopback check which will also could related promopt popup issue:
    Disable “LoopBackCheck” for SharePoint Server

  3. If the issue still exists, I suggest you can trace the request using Fiddler or Chrome Developer Tool to see the detailed reponse data.

  4. If nothing can be found in Fiddler, try to check SharePoint ULS log for a furthur troubleshooting.

Here is a similar question for your reference:

SharePoint App giving credentials popup




If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Disabling LoopbackCheck is only useful when using IE on the particular SharePoint server (accessing a Web App locally, for example).

0 Votes 0 ·
DerryRedwine-8159 avatar image
0 Votes"
DerryRedwine-8159 answered

Try this...

  1.  Open Chrome and type “chrome://flags” in the address bar.
    
  2.  Change the following items to Disabled.
    
  3.  Hit Restart. 
    

41191-chrome.png



chrome.png (38.4 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.