Azure Document Intelligence error 404 when using API version 2023-10-31

Butu, Irina 0 Reputation points
2024-02-05T17:02:31.0433333+00:00

Hello!

I came across a strange "404" error when trying to use my latest trained models with their API versions
(2023-10-31).
User's image

The only chance I can use the output from these new models is to downgrade the api-version to 2023-02-28.

What might be the cause for this...?

Thank you in advance for your response!

Azure AI Document Intelligence
Azure AI Document Intelligence
An Azure service that turns documents into usable data. Previously known as Azure Form Recognizer.
1,203 questions
{count} votes

1 answer

Sort by: Most helpful
  1. YutongTie-MSFT 43,076 Reputation points
    2024-02-06T00:04:20.7233333+00:00

    @Butu, Irina

    Thanks for reaching out to us, updated the API version to the latest version or a stable version is very important to keep everything working well. Preview APIs are periodically deprecated. If you're using a preview API version, update your application to target the GA API version.

    Since you are using a preview version which is not GA and updated, have you already migrated from Form Recognizer to Azure AI Document Intelligence as below guidance?

    https://github.com/Azure/azure-sdk-for-python/blob/main/sdk/documentintelligence/azure-ai-documentintelligence/MIGRATION_GUIDE.md

    Please take a look to see if this is related to your issue, please let us know how it works, I hope this helps.

    Regards, Yutong

    -Please kindly accept the answer if you feel helpful to support the community, thanks a lot.

    1 person found this answer helpful.
    0 comments No comments