Azure CLI (command az login) is not able to detect any subscriptions in account

Rayan Chowdhury 0 Reputation points
2024-03-20T14:54:58.4166667+00:00

Tried to connect my azure account and had installed the Azure CLI, tried running the command az login but even though I have an active 'Azure for Students' subscription and the status shows running, plus I have admin level permissions too (checked through IAM) but still when am trying to run az login and set the subscription with the subscription id it is still not connecting

Azure Cost Management
Azure Cost Management
A Microsoft offering that enables tracking of cloud usage and expenditures for Azure and other cloud providers.
2,008 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Andreas Baumgarten 95,496 Reputation points MVP
    2024-03-20T15:10:13.1933333+00:00

    Hi @Rayan Chowdhury ,

    are you using az login with providing a Tenant-ID? For instance az login --tenant 00000000-0000-0000-0000-000000000000

    Do you get an error message after running az login?

    After signing in with az login you can set the subscription using az account set --subscription "<subscription ID or name>".


    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards

    Andreas Baumgarten