Microsoft Print to PDF stops working on 2016 RDSH after installing KB4586830

acira 16 Reputation points
2020-11-17T19:42:42.307+00:00

I have a deployment of 7 2016 RDSH servers.
After installing KB4586830 Microsoft Print to PDF and Microsoft XPS Write stops working.
If I uninstall KB4586830 it fixes the issue.

Does anyone have a solution other than uninstalling the security patches?

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,755 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
3,034 questions
Windows Server Printing
Windows Server Printing
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Printing: Printer centralized deployment and management, scan and fax resources management, and document services
495 questions
{count} votes

16 answers

Sort by: Most helpful
  1. mrbenjamine20 11 Reputation points
    2021-09-22T20:07:18.56+00:00

    Not sure if this is the exact same issue, but we had various Print to PDF and Type-4 driver installation issues. I posted what resolved it for me, here- https://learn.microsoft.com/en-us/answers/questions/214615/microsoft-print-to-pdf-not-working-after-windows-u.html

    Here are my notes on what worked for us-

    One thing I noticed was that the ntprint.inf file was referencing ntprint.inf_x86... for the active driver reference on the problematic machine, ntprint.inf_x64... on a working machine

    I did the following and so far printing is back to normal for Type-4 drivers-

    1- ran "pnputil /enum-drivers" from a command prompt
    2- used psexec to elevate and run regedit as system
    3- investigated the - HKEY_LOCAL_MACHINE\DRIVERS\DriverDatabase\DriverInfFiles\ntprint.inf
    4- updated the (Default) value to include - ntprint.inf_x86_6fbb4b09e9354bf2 and ntprint.inf_amd64_6fbb4b09e9354bf2
    5- updated the Active value to - ntprint.inf_amd64_6fbb4b09e9354bf2

    Note- the exact values of ntprint.inf_x86 and _64 might be specific to build or updates installed, I'm not sure that they are universal to 2016. I used the values that existed in the DriverStore - C:\Windows\System32\DriverStore\FileRepository on my servers.

    Not sure if this fix will do the trick long term, but so far after scrubbing out old printers, drivers, and pretty much cleaning out all registry / driver on the server its the only thing that has looked promising. Hopefully this will help point someone else in the right direction.

    To recap the issue we had- On six Windows 2016 RDS session hosts last year, printing worked fine until April time frame and none of the Print to PDF or installing any printer with a type-4 driver would work. We would always get "Element not found" June 2020 we rebuilt new fully patched Windows Server 2016 RDS session hosts and the problem was resolved until 2 months ago when the exact thing happened again! Very frustrating. With limited testing at this point, editing the ntprint.inf entry in the registry seems to have resolved.


  2. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,436 Reputation points Microsoft Employee
    2020-11-18T03:50:16.307+00:00

    Hi,

    I have do a lab test to install KB4586830 on one 2016 Server and remote connect to it. I got no issue. So, the issue should not be related to this KB.

    After researching, I found KB4457127 which contains the information of your issue.
    https://support.microsoft.com/en-us/help/4457127

    Addresses an issue that causes printing to an open or existing file to fail without displaying an error message. This issue occurs when using Microsoft Print to PDF or XPS Document Writer.

    Please run powershell command "get-hotfix" to show the KB list you have installed. And try to install KB4457127 to see if you could resolve the issue.

    Thanks,

    Eleven

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

    No comments

  3. acira 16 Reputation points
    2020-11-18T15:20:30.213+00:00

    It is also happening on a stand alone RDSH not using UPDs that I just checked. Printing to One Note works.

    I cannot find KB4457127 to try, it is not in the catalog.


  4. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,436 Reputation points Microsoft Employee
    2020-11-19T07:19:01.647+00:00

    Hi,

    Please first try the methods in below article to see if your issue could be resolved/

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_other-mso_win10-msoversion_other/microsoft-print-to-pdf-has-quit-working/d205f15b-22d9-4916-81fd-2ac4a9d30a6b

    Thanks,

    Eleven

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.


  5. PM 1 Reputation point
    2020-11-21T11:15:04.96+00:00

    Bonjour,
    Même problème rencontré sur 2 rdsh sur 15.
    Voilà ce que j'ai fait pour rétablir ma situation
    Avec patch PrintToPDF ko
    PS C:\WINDOWS\system32> Disable-WindowsOptionalFeature -Online -FeatureName Printing-PrintToPDFServices-Features
    puis
    PS C:\WINDOWS\system32> Enable-WindowsOptionalFeature -Online -FeatureName Printing-PrintToPDFServices-Features
    finit en erreur
    remove kb reboot
    PS C:\WINDOWS\system32> Enable-WindowsOptionalFeature -Online -FeatureName Printing-PrintToPDFServices-Features
    OK
    PrintToPDF ok
    install kb reboot
    Avec patch PrintToPDF OK

    si ça peut aider