Windows Performance Recorder - Error 0xc5583017 - The shutdown recording is already enabled and pending stop

Anon 0 Reputation points
2024-05-28T10:38:35.7933333+00:00

Hi,

I'm having a problem with WPR. I tried to run a reboot cycle performance check. I restarted the computer, however, I haven't been able to save the results since then (or even stop the recording).

Every time I launch WPR (GUI), it says: Status: Recording selected profiles in Memory... Buffer 780 MB (6%), Events dropped: 0 (and I can theoretically Save it or Cancel - both options don't seem to work at all). When I click on the Save button, I'm getting: There are no trace profiles running.

When I run WPR via CMD as Administrator and want to use -cancel flag, I'm getting the following: There are no trace profiles running.

When I try to run e.g., wpr -start registry (or whatever) I'm getting:

The shutdown recording is already enabled and pending stop. Profile Id: <empty> Error code: 0xc5583017

The version I'm currently using is Windows Performance Recorder Version 10.0.20348 - I had tried the latest version as well, then downgraded to 10.0.20348.

Fortunately, this is happening on a test computer, however, it prevents me from using WPR on any server for the moment :( - I cannot risk of running into the same problem on a production server.

Regards,

Windows Performance Toolkit
Windows Performance Toolkit
A collection of Microsoft performance monitoring tools that produce in-depth performance profiles of Windows operating systems and applications.
93 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Anon 0 Reputation points
    2024-05-28T12:42:25.2366667+00:00

    I was able to solve the problem in the following way:

    1. Uninstall Windows Performance Toolkit
    2. Remove the entire Registry Key associated with Windows Performance Toolkit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Performance Toolkit
    3. Re-install Windows Performance Toolkit.

    From now on, WPR is working fine. It's not necessary to uninstall WPT every time, just delete the registry key and re-run WPR.

    Regards,

    0 comments No comments