Sandbox Subscription won't dismiss and Forever Error on Exercise - Create an Azure virtual machine (Unit 3) in Describe Azure architecture and services

js231 0 Reputation points
2024-06-14T17:32:25.4+00:00

Hi all,

I am taking the Microsoft Azure Fundamentals Online Course on Microsoft Learn.

While I worked on Exercise to Create an Azure Virtual Machine in "Describe Azure Compute and Networking Services", I kept receive errors.

I had followed through the instructions, activated the Azure Sandbox, copy and paste the command:
az vm create \ --resource-group "learn-8cca6b48-7960-4a20-b1a0-1d5023ac4df1" \ --name my-vm \ --public-ip-sku Standard \ --image Ubuntu2204 \ --admin-username azureuser \ --generate-ssh-keys

I received error message:

(AuthorizationFailed) The client 'live.com#XXXXXX@XXXXXX.com' with object id '68bc96a4-7328-4aef-bbfa-96fea79304ee' does not have authorization to perform action 'Microsoft.Resources/subscriptions/resourcegroups/read' over scope '/subscriptions/f26515d9-3bc6-4a50-8192-cb816a833f54/resourcegroups/learn-8cca6b48-7960-4a20-b1a0-1d5023ac4df1' or the scope is invalid. If access was recently granted, please refresh your credentials.

Code: AuthorizationFailed

Message: The client 'live.com#XXXXXX@XXXXXX.com' with object id '68bc96a4-7328-4aef-bbfa-96fea79304ee' does not have authorization to perform action 'Microsoft.Resources/subscriptions/resourcegroups/read' over scope '/subscriptions/f26515d9-3bc6-4a50-8192-cb816a833f54/resourcegroups/learn-8cca6b48-7960-4a20-b1a0-1d5023ac4df1' or the scope is invalid. If access was recently granted, please refresh your credentials.

** I had masked the email address in the error message **

I attached the capture for reference as well.

User's image

Then I search on internet and Q&A, some others had posted the similar problem they had faced. I had tried all suggested solutions, including jumping to Unit 9 of 14 to allow creating the "learn-xxxxx", I can see from portal.azure.com that "learn-xxxx" is created. But the error still exist.

User's image

And next I tried to follow the posts which one of the post was suggested by Microsoft Vendor, to follow some steps, including:

  • sign out of existing azure portal completely
  • sign out azure cloud shell completely
  • activate new sandbox
  • verified resource group name are same
  • refreshed sandbox environment

I also tried:

  • clear all browser caches and history
  • use different browser
  • run browser Incognito mode

but NO LUCK and still receive ERROR messages.

Another funny thing is that, I found 2 "Concierge Subscription" always stay in the Subscriptions, which they did not dismiss along with Sandbox previously did the exercises.

And there is no way to remove it.

User's image

Altogether, it comes up I cannot follow the instructions to complete the exercises. and my Azure account got 2 subscriptions in the sandbox directory.

Can anyone share if you may have the same problems and is there anyways can resolve it? so I can continue to do the exercises?

Hope any one of you who knows this and can share info, please share and help me to resolve.

Thank you.

Azure Training
Azure Training
Azure: A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.Training: Instruction to develop new skills.
1,297 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. AmaranS 3,860 Reputation points Microsoft Vendor
    2024-06-15T01:31:50.8366667+00:00

    Hi js231,

    Thank you for reaching out to us on the Microsoft Q&A forum.

    We understand you are experiencing issues creating a VM in the sandbox while working through the module "Describe Azure compute and networking services."

    Here are the troubleshooting steps to resolve the issue:

    1. Sign Out of Existing Azure Portal: Ensure you completely sign out from the Azure portal created in the previous module unit "Exercise - Create an Azure resource," which has an active Microsoft Learn sandbox directory with a Concierge subscription.
    2. Sign Out of Azure Cloud Shell: Sign out completely from the existing Azure Cloud Shell sandbox or wait until the sandbox activation time expires.
    3. Activate a New Sandbox: Click on the "Activate Sandbox" button to activate a new sandbox. This will create a default subscription called "Concierge subscription" along with a default resource group name starting with "learn." We recommend using a different browser or an incognito/private window to rule out any browser-related issues.
    4. Verify Resource Group Name: Sign in to the Azure portal and verify that the resource group name used in the "az vm create" command matches the one displayed in the Azure portal for the sandbox environment.
    5. Refresh the Sandbox Environment: Since you lack permission to modify the sandbox environment and the error indicates an authorization problem, the most effective solution is to refresh the Microsoft Learn sandbox environment. This will recreate the environment with the appropriate permissions.
    6. Follow Microsoft Learn Instructions: Follow the instructions provided in the exercise within the Microsoft Learn document. These instructions are tailored for the sandbox environment and often use Cloud Shell commands to avoid permission issues. Ensure you are running the Azure CLI commands in the correct directory (Microsoft Learn Sandbox) and with the correct subscription selected.

    Please note that modifying permissions in the Microsoft Learn sandbox is restricted to prevent unintended consequences. The Concierge Subscription is automatically created for sandbox environments to provide necessary resources, and we do not have permission to delete or modify it due to these inherent restrictions.

    Also, in a sandbox environment, the access control configurations are pre-set and typically cannot be modified by the user.

    If you continue to face issues, please let us know in the comments. We are here to help.

    If you find this information helpful, please acknowledge by clicking the "Upvote" and "Accept Answer" buttons on the post.