The credentials provided for the AzureBlobs source is not working

Villealdrich Vilanio 0 Reputation points
2024-06-20T10:51:37.9166667+00:00

Hi,

We are having some authentication issue while refreshing dashboard in powerBi. It is currently linked to Azure Blob storage via SAS key. We already tried to add Azure IP address to the whitelist but we still encounter the same error.

User's image

If we change the settings to "Enabled from all Networks", the refresh is always successful. Also, the weird thing is that we only encounter the issue on PowerBI web, if we try to refresh using the powerBi desktop it is also a success.User's image

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,627 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Nehruji R 4,606 Reputation points Microsoft Vendor
    2024-06-21T08:12:27.9+00:00

    Hello Villealdrich,

    Greetings! Welcome to Microsoft Q&A Platform.

    I understand that you’re encountering an issue when refreshing your Power BI dashboard connected to Azure Blob storage via a SAS key with error "The credentials provided for the Azure Blobs source are invalid" is because of any change in authentication method for your data source connection.

    Ensure that you’re using the correct type of SAS key. Azure Storage supports three types of shared access signatures (SAS):

    User delegation SAS: Secured with Microsoft Azure AD credentials and applies to Blob storage only.

    Service SAS: Secured with the storage account key and delegates access to a resource in one of the Azure Storage services (Blob storage, Queue storage, Table storage, or Azure Files).

    Account SAS: Also secured with the storage account key, it delegates access to resources in one or more storage services.

    The error message suggests that the credentials provided are invalid. One possible reason is that you’re using a Service SAS instead of an Account SAS. When performing operations at the account level (such as listing blob containers), you need an Account SAS and verify that the SAS token you’re using is the same in both environments.

    refer - https://powerbi.microsoft.com/en-us/blog/adls-gen2-and-azure-blobs-sas-key-connectivity/

    Since Power BI Desktop works fine when you set the configuration to “Enabled from all Networks,” it allows access from any IP address. However, this might not be the most secure option and not refreshing when using selected network, it suggests that the issue might be related to network restrictions or firewall rules specific to Power BI web. Double-check if there are any network-level restrictions (such as firewalls, proxies, or VPNs) that could be affecting the connection between Power BI web and Azure Blob storage.

    Check the account under which Power BI web is running. Ensure that it has the necessary permissions to access the Azure Blob storage. Sometimes browser extensions or security settings can interfere with web applications.

    Try accessing Power BI web from a different browser or an incognito/private browsing window to rule out any browser-related issues. If issue still persists, please reach the experts in the dedicated Power BI forum over here: https://community.powerbi.com/t5/Forums/ct-p/PBI_Comm_Forums for further troubleshooting. As Power BI is currently not supported in the Q&A forums, the supported products are listed over here https://learn.microsoft.com/en-us/answers/products.

    Hope this answer helps! Please let us know if you have any further queries.


    Please "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.

    0 comments No comments