Azure APIM self-hosted gateway different logs

Rudolf Matuszek 0 Reputation points
2024-06-25T18:00:55.5633333+00:00

Hello, I need help with Azure APIM self-hosted gateway.

I am running it in podman v3.4.2 container and using Anisble AWX to deploy it. It works fine, but after I tried to export logs to separe file via log-driver: json-file, it started to log weird logs with almost no info. I tracked my steps and did a rollback to previous configuration which was logging into localsyslog, but even after rollback, same logs are being logged into localsyslog.

For example:

Standard logs that I need to export:

Jun 25 17:08:57 <hostname> apimuser[3]: Timestamp=2024-06-25T17:08:57.9082684Z, isRequestSuccess=true, totalTime=44, category=""GatewayLogs"", callerIpAddress=""xxx"", timeGenerated=2024-06-25T17:08:57.9082684Z, region=""Czech\ Republic"", correlationId=""xxxx"", method=""GET"", url=""xxx"", responseCode=200, responseSize=143, cache=""none"", backendTime=43, apiId=""health"", operationId=""health"", apimSubscriptionId=""xxx"", clientProtocol=""HTTP/1.1"", apiRevision=""1""

And somehow when I switch to json-file, no matter if it logs to spare file or syslog I get this:

Jun 25 17:40:23 <hostname> apimgw[1333531]: {"level":"Informational","timestamp":"2024-06-25T17:40:23.8988516Z","message":"<backendurl>","source":"RoundRobinNameResolver"}

And that's all..

I also tried to delete whole pod and recreate it, but I was not able to reverse the log "format" to the proper one.

Can someone help me with what could be the cause and/or how to resolve this? Thank you.

Rudolf.

Azure API Management
Azure API Management
An Azure service that provides a hybrid, multi-cloud management platform for APIs.
1,940 questions
0 comments No comments
{count} votes