Microsoft Login Prompt in Outlook

Marc Molling 20 Reputation points
2024-06-26T11:41:00.14+00:00

Hello Community

Currently our mail.accounts are on an outside cloudbizz server.

So when i add an account to outlook, normally a Windows Popup will ask me to introduce the mailbox Credentials....

Bus since yesterday, i have one account (so far) where i always get a Microsoft Prompt. When i close this prompt, i will sometimes get the Windows prompt, so i am able to configure the mail account as a 2dn account on my outlook.

But from here on, when i open my Outlook, everything is fine and connected for 30 secondes, and then i get the Microsoft Prompt again. With the prompt open, the mailbox stays connected. Only when i close it, it gets deconnected saying "Password required" in the bottom line on the right.

Do you may have any idea why this is happening, and how i can get rid of it.

thank you

Best regards

Microsoft Exchange Online
Outlook
Outlook
A family of Microsoft email and calendar products.
3,401 questions
Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
4,373 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,492 questions
0 comments No comments
{count} votes

Accepted answer
  1. Mike Hu-MSFT 2,180 Reputation points Microsoft Vendor
    2024-06-28T08:36:41.36+00:00

    Great to know that the issue has already been resolved and thanks for sharing the solution so that others experiencing the same thing can easily reference this! Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others", I'll repost your solution in case you'd like to "Accept" the answer : )     

    --------------   

    Issue Symptom: 

     Currently our mail.accounts are on an outside cloudbizz server.

    So when i add an account to outlook, normally a Windows Popup will ask me to introduce the mailbox Credentials....

    Bus since yesterday, i have one account (so far) where i always get a Microsoft Prompt. When i close this prompt, i will sometimes get the Windows prompt, so i am able to configure the mail account as a 2dn account on my outlook.

    But from here on, when i open my Outlook, everything is fine and connected for 30 secondes, and then i get the Microsoft Prompt again. With the prompt open, the mailbox stays connected. Only when i close it, it gets deconnected saying "Password required" in the bottom line on the right.

    **Resolution:**Adding the account as Exchange 2013 or older and putting the following in the Registry:

    Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover and create DWORD key ExcludeExplicitO365Endpoint=1

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Mr. Trust_A 0 Reputation points
    2024-06-26T15:22:21.1466667+00:00

    Hi Marc,

    The issue you're describing with Outlook repeatedly prompting for credentials can be caused by several factors. But perhaps you can try clearing the cached credentials by doing the following steps (assuming you are using Windows):

    • Open Credential Manager on your Windows machine.
    • Go to Windows Credentials.
    • Look for any entries related to your email account or the mail server.
    • Remove those entries.
    • Restart Outlook and try to set up the account again.

    Hope this helps,

    Regards,

    0 comments No comments

  2. Marc Molling 20 Reputation points
    2024-06-27T06:29:52.3733333+00:00

    Hello

    Yes i already tried this. but it changes nothing. It's rewind and repeat....

    Our IT provider gave me something to try out what seems working:

    Adding the account as Exchange 2013 or older and putting the following in the Registry:

    Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover and create DWORD key ExcludeExplicitO365Endpoint=1

    Although this work for the moment, i try to understand where the problem is initially comming from