How can I access my lost documents?

Eskandar, Shirin 0 Reputation points
2024-06-29T16:52:53.5633333+00:00

I was working on a word document. I updated that several times and saved the latest changes anytime I closed it. Last time I saved it I couldn't find the latest changes. The file which was saved was the one I created several days ago.

Office Mac
Office Mac
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Mac: A family of Apple personal computers that run the macOS operating system.
483 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Jiajing Hua-MFST 7,625 Reputation points Microsoft Vendor
    2024-07-01T02:01:17.0833333+00:00

    Hi @Eskandar, Shirin

    • If you enabled "AutoRecovered" feature, I suggest you go to Finder, then click Go > Go To Folder (or press SHIFT + COMMAND + G) and enter the /Users/_<username>_/Library/Containers/com.Microsoft/Data/Library/Preferences/AutoRecovery, check whether there is any AutoRecovered file. The reference: Recover files in Office for Mac
    • If you save the file in OneDrive, then please sign in to OneDrive and select the file you want to restore to an earlier version with right-click then Version history. Select the ellipses (…) and then click Restore. For your reference: Restore a previous version of a file stored in OneDrive

     

    • If you save file on local machine and use Time Machine to backup, you may open Time Machine, use the arrows and timeline to browse the local snapshots and backups. Select the items you want to restore.

    Hope the information could be helpful.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


    0 comments No comments