Print issue in Encompass application

Shelly Kapoor 20 Reputation points
2024-07-02T09:51:13.9733333+00:00

Users on azure virtual desktop facing a issue that print service on encompass application is not working it will take more time to print print redirection is enable hybrid user what we can do to resolve issue.

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,448 questions
0 comments No comments
{count} votes

Accepted answer
  1. Nikhil Duserla 970 Reputation points Microsoft Vendor
    2024-07-02T18:33:29.66+00:00

    Hi Shelly Kapoor ,

    Welcome to the Microsoft Q&A Platform! Thank you for asking your question here.We understand from your query that your users are experiencing an issue with the print service on the Encompass application, where printing takes a long time or doesn't work at all.

    Please work on these steps given below:

    Check Print Redirection Settings: Verify that print redirection is correctly configured on the AVD host pool and the Encompass application. Ensure that the print redirection settings:

    Navigate to Group policy settings

    Create GPO for AVD session host>>User Configuration>> Policies>>Administrative Templates>> Windows Components>>Remote Desktop Services>>Remote Desktop Session Host>>Printer Redirection. Enable Policy “Do not allow client printer redirection” to temporarily disable printer redirection for all printers.

    Registry Edits:

    In the same GPO navigate to Computer Configuration>>Preferences>>Windows Settings>> Registry.

    Create new registry: Action: Update

    • Hive: HKEY_LOCAL_MACHINE
    • Key Path: SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
    • Value name: FDisableCpm
    • Value type: REG_DWORD
    • Value data: 0

    Apply GPO

    This configuration should disable printer redirection for all printers and then re-enable it only for local printers.

    Ensure that the Azure Virtual Desktop Agent is up-to-date and running correctly on the AVD host pool. You can try updating the agent or reinstalling it to resolve any issues.

    Check if the user's profile is causing the issue. Try logging in with a different user account or resetting the user's profile to see if the issue persists.

    Check the network connectivity between the AVD host pool, the print server, and the user's device. Ensure that there are no firewall or network configuration issues blocking the print traffic.

    If you have any further queries, do let us know.

    If the answer is helpful, please click "Accept Answer" and "Upvote it."


0 additional answers

Sort by: Most helpful