In MS Teams for linux, microphone stopped working

Christine 81 Reputation points

I installed MS Teams for Linux on Ubuntu 20.04 a few weeks ago. It worked perfectly well, until earlier this week, the microphone stopped working. I have a mic in my headset, and a mic in the Logitech camera, both work ok for all applications, except with Teams. When I use the mic, I see the record sound meter in Ubuntu sound record it, but the Teams sound meter in "settings" doesn't.
What can I do?


This morning, audio worked on MS Teams. But when the meeting actually started, a popup appeared saying "your microphone does not work" and it stopped working. It must be a bug in MS Teams, otherwise it couldn't have worked for the first 5 minutes.

Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
456 questions
{count} votes

16 answers

Sort by: Most helpful
  1. Main User 61 Reputation points

    I had the same problem. Here is how I solved this:
    If not already installed, install the PulseAudio volume control tool (sudo apt install pavucontrol)
    Then, while Microsoft Team is running, open the "PulseAudio volume control" application.
    Go in the Recording tab: you should see a mic volume slider for "Skype" (The Skype engine is probably used in Microsoft Team).
    (If you don't see "Skype", be sure "Applications" is selected in the dropdown at the bottom of the Recording tag.)
    Move the slider just a little to the right or to the left.
    Then redo a Call Test in Teams. Now it should work.
    After that, you can put back the slider exactly where it was, at 100% (0dB) and close the PulseAudio tool.

    12 people found this answer helpful.

  2. Some Guy 11 Reputation points

    I have Teams on Kubuntu 18.04 and the microphone did not work at all - or so it seemed.

    I installed PulseAudio Volume Control (sudo apt install pavucontrol), started it, opened the Recording tab and made sure the menu on the bottom right said Applications.

    Then I went to Teams -> Settings -> Devices -> Make test call.


    As soon as the test call starts, I can see (red arrow) that Teams (appears as "Skype") does not use my headset like it said it would. Instead, it falls back to the internal microphone (which is switched off).

    So I can use Teams now, but I will have to open PulseAudio Volume Control every time and upon every single call, use PulseAudio Volume Control to force Teams to use the correct microphone (use dropdown at red arrow) and not randomly go off and choose something else.

    2 people found this answer helpful.

  3. JimmyYang-MSFT 49,441 Reputation points Microsoft Vendor

    Hi @Christine ,

    Does this issue persist when using Teams web client?

    Please make sure you are login as a root user to your system GUI and not as some other user. Then check if you have installed the pulseaudio and ensure they are running in your environment. For more details about it, you can refer to this blog:

    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  4. Simon Alexander Alsing 11 Reputation points

    @Christine I got the same issue, it was happening a bit before I upgraded to fedora 34, but not as persistent and often as now. fedora33-34 upgrade changed from pulseaudio to pipewire. I don't know if that relates to your situation, but I think that it might have something to do with that change.

    So I tried to start the application with pw-jack teams and my first call went flawlessly, maybe it is a solution ? I'll report back when I've tested it some more.

    0 comments No comments

  5. JonG 1 Reputation point

    I have the same issue for Debian with pulseaudio.

    Problem occurs somewhat randomly, but often will occur if I have a missed call, or answer an incoming call rather than a meeting.

    As a workaround, quit Teams before your meeting and restart it. In fact, I often restart Teams after a meeting so that it is ready for the next meeting.

    0 comments No comments