AndersonZanardi-6866 avatar image
0 Votes"
AndersonZanardi-6866 asked eberdev commented

Custom PHP extensions no longer load

Recently, more precisely on Nov 19, 2019, I had a problem where when scaling my application the new instances that scaled no longer found the extensions I use on my system.

Some of my users connected to a given instance could load the system correctly, another part was in error because the extension had not been loaded.

I could even see from phpinfo in both scenarios that the extensions were not loaded.

I spent a few hours having to run my application without scaling and then having no errors. Consequently I had high response time issues.

After a few hours, even instances that were normally loading extensions had the same behavior: they could no longer load extensions.

Anyway, I imagine there was some structure change in the way Azure runs PHP and it wasn't disclosed to us.

I had a similar problem last year, where the "PHP_EXTENSIONS" setting no longer worked when PHP went from 5.6.38 to 5.6.39. From that day I had to implement the configuration "PHP_INI_SCAN_DIR". Since then everything has been working well. But from the 19th, I had the problem that neither of these configurations solved.

I had to move my system to PHP 7 in a hurry and in this case everything worked.

I wonder if you know what may have happened.

Why do these internal Azure updates sometimes generate this kind of behavior?

Is there any way I can protect my environment from this kind of behavior?

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Are you using Azure App Service on Windows to run PHP apps? Based on various indicators (such as the announcement of Python support on Windows side), you should run your apps on its Linux counterpart to gain best experience,

0 Votes 0 ·

@AndersonZanardi-6866 Are you still facing issue? Request you to send an email to AzCommunity[at]Microsoft[dot]com referencing this issue, we will closely look into this.

0 Votes 0 ·

Hello, I had to upgrade my application to PHP 7 and it worked. Unfortunately, I did not maintain the environment with PHP 5.6 to see if the problem persists.

My concern is these internal maintenance that Microsoft periodically does that sometimes cause inconvenience.


0 Votes 0 ·
eberdev avatar image eberdev AndersonZanardi-6866 ·

Its far more plausible it was the configuration of your workload that was causing the issues. Based on what i read it may simply be that you had the wrong PHP version selected in the app settings. This is found under "configuration -> General Settings" if you have PHP selected as the stack then you have many choices on the version. v 5.6 then 7 thru 7.3. Microsoft will never change these values during any maintenance or patching session.


0 Votes 0 ·

0 Answers