Consent screen is not appearing when auth app changes the list of existing scope

WMio Connectors 121 Reputation points

Hi Team,

I created one AAD app and added A, B, C Permissions and user authorize app via granting permission from their admin. But as an OAuth app owner, if I add more permissions let b x,y and when user retry to authorize. New consent screen is not appearing with added permissions. It directly provides access token with old scopes(A, B, C).

So how can I make the user get consent screen for every change in scope of request call

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
14,914 questions
0 comments No comments
{count} votes

Accepted answer
  1. WMio Connectors 121 Reputation points

    @soumi-MSFT I tried using v1.0 oauth2. In v1.0 there is no way for providing scopes. So how this can be achieved in v1.0?

1 additional answer

Sort by: Most helpful
  1. soumi-MSFT 11,651 Reputation points Microsoft Employee

    @WMio Connectors , For the time being you can mention the new Permissions in the scope (in case using v2.0 endpoint) of the Request URL and try. I tried the same and it works for me. Bookings.Read.All&state=12345

    Bookings.Read.All, is the new Permission that I added and tested and it appeared in the Consent Page.

    Hope this helps.

    Do let us know if this helps and if there are any more queries around this, please do let us know so that we can help you further. Also, please do not forget to accept the response as Answer; if the above response helped in answering your query.