"Create App Service Managed Certificate" is broken


"Create App Service Managed Certificate" is broken in Azure Web App for Linux (Plan B1). When I create a certificate Azure returns a message "Successfully created App Service Managed Certificate for #######.com" however no cert shows up in the Private Key Certificates list. I repeated the processes with the same result. I also logged out and in, repeated the certificate generation process and still no certificate appears.

Azure App Services
Azure App Services
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,555 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. ajkuma 14,086 Reputation points Microsoft Employee

    Welcome to Microsoft Q&A! Thanks for posting this question.

    I just tested/repro'd creating a Managed Certificate and was able to create it fine. Could you please let us know on which region have you hosted your app?
    alt text

  2. Anonymous

    Hi, East US. There was a greater issue going on with a previous Orphan certificate. You can reproduce the issue by creating a Azure Web App (Windows) and corresponding certificate and binding. Then delete the Web App (without deleting the certificate first). Then create an Azure Web App (Linux) with the same name and domain as the Windows Web App. Then try to recreate the certificate. It will return a certificate creation success message but not create the cert.

    The full story and solution: I had an Azure Web App (Windows) and deleted it to create an Azure Web App (Linux) with the same name. I created a "App Service Managed Certificate" with the Azure Web App (Linux) however the certificate will not show up in the certificate list. I can see the previous certificate in Azure Resource Explorer, however the Actions (POST,DELETE) tab is greyed out preventing me from deleting the certificate. I am the admin on the account and I clicked the "read/write" button. I followed these steps to delete the previous cert which finally permitted me to create a new cert.

    Follow these steps exactly. There is a similar path in the tree that looks the same but will not let you delete the certificate there even though you can view it.

    1. Navigate to Subscriptions >> resourceGroups >> YourResourceGroup >> Provider >> Microsoft.Web >> Certificates
    2. Navigate to the certificate that is the same thumbprint.
    3. Make sure you are in the Read/Write mode (toggle it at the top of the screen)
    4. Click on the Action/Delete
    5. Click on the Delete button to delete the certificate resource explorer >> subscriptions >> >> resourceGroups >> >> providers >> Microsoft.Web >> Certificates >> (read/write mode) delete the certificate