SharePoint open file explorer’ behaviour is inconsistent of SharePoint web application which is integrated with SSO

vinothkumar 1 Reputation point

Hi Team :

we observing that SharePoint ‘open file explorer’ behaviour is inconsistent of SharePoint web application which is integrated with SSO.
We suspect the issues with Windows Service “WebClient” (which is used by WebDAV protocol). The windows service needs to be restarted each time to open SharePoint file explorer. Windows WebDAV access might cache certain operations.
This leads to problem when SharePoint open file explorer relies on a consistent state.

Therefore, we are looking some Windows expert to look this issue.

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,789 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Mohamed El-Qassas 1,381 Reputation points MVP

    I am not a Windows expert. however, I would suggest to make sure that the WebDav (Web client) service is running and log on as a Local Service and its startup type is set to Automatic.

    Besides that, I also recommend checking this article We’re having a problem opening this location in File Explorer, Add this web site to your Trusted Sites list and try again that provides guidelines and solutions for Open With Explorer issue in SharePoint.

    0 comments No comments

  2. Emily Du-MSFT 41,371 Reputation points Microsoft Vendor

    Agree with melqassas. Please go to windows services, check whether the startup type of WebDav service is set to automatic and the log on account is set to local service.

    You could go to ULS logs to find more clues.

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments