Azure VM access

Yan Gar 1 Reputation point


Just registered with Azure, deployed new VM & not able to connect right from the start.

message I get is in attached picture. 50954-capture.jpg

I have tried to access from mobile Azure app & same story:

We couldn't connect to the remote PC because th PC can't be found
Error Code: 0x104

I have tried to restart VM, troubleshoot etc. but it says everything is fine....

Please Help,

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
4,924 questions
{count} votes

1 answer

Sort by: Newest
  1. Andreas Baumgarten 67,636 Reputation points MVP

    Most common reason is a "blocking" Network Security Group (NSG) with a missing RDP inbound rule:

    NSGs can be associated with a VM and/or with the subnet. You should check both options.

    Some more detailed troubleshooting steps you can find here:


    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Andreas Baumgarten