Closing the window does not close the Program

Ben Johnston 16 Reputation points

I am running PopOS (Ubuntu) 19.10

Closing the teams window using the X in the top right button does not actually close the program, with processes still running in the background. I am running GNOME 3.34.2. I have installed the KStatusNotifications GNOME extensions and noticed that selecting Quit using this menu does in fact close the program.

I have teams version (64 bit).

Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
456 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Nicholas Fiorello 16 Reputation points

    Except That setting defaults to ON.
    Except You must be signed in to change settings.
    Except... You have to change that setting even if all you want to do is 'exit teams for the day' and have it re-enabled in the morning.

    This isn't Max Headroom, it's not illegal to close Teams no matter how much you 'd like it to be that way.

    Give us an exit command.

    3 people found this answer helpful.

  2. Marian Javorka - MSFT 936 Reputation points Microsoft Employee

    Thank you for your feedback @Ben Johnston

    There is in-app setting to change this behaviour. Go to Settings from Profile menu


    And then uncheck the second item on this screen


    2 people found this answer helpful.

  3. Steve Sommers 6 Reputation points

    Nothing like Microsoft breaking their own standard for other apps to follow.

    1 person found this answer helpful.
    0 comments No comments

  4. JimmyYang-MSFT 50,446 Reputation points Microsoft Vendor

    Hi BenJohnston-0978!
    Yes, you're right!
    If you only close the teams windows using "X" in Teams client, it does not actually close the program. You should click Teams icon and select quit to close the program. It should be the expected behavior.

    0 comments No comments