How do I remove Phantom Drives from Win 10

adiggens 1 Reputation point

I bought a new SSHD for my laptop and I cloned it using AOMEI and a USB adapter. The cloning went of without a hitch. I shut the computer down and replaced the old drive with the new drive. The original drive letter is D:. When I restarted the new drive showed up as E: not D:. The D: drive still shows up as Local D: with a question mark.

I right clicked on the drive and look at the properties it shows no names, used space or free space. That is it.

I went into Device Manager and viewed hidden drives and uninstalled the old drive as well as gone into the registry and removed the drive from mounted devices.

I went into Disc Management and tried to change the drive letter and it wouldn't let me. I could pick the drive letter then it would give an error that "the parameter is incorrect".

I have tried mountvol <drive> /D without any luck as well.

I have also put the original drive back in, uninstalled the drive, restarted without the drive in it and the Local D? still shows up.

Anyone have a fix?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
30,481 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Dale Kudusi 3,221 Reputation points

    Please check if you still experience the issue in Safe mode:

    then try assigning the drive letter in Disk Manager while in safe mode.

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments