Can't verify Azure Web App domain against Google Domain Verification

Luca Bortolotti 96 Reputation points
2020-04-14T19:56:00.57+00:00

I added to my web app the Google Login as described here: configure-authentication-provider-google
and I could follow all the steps, the problem is that when I tried to load the webapp, Google auth replied with an error.
The problem is that I have to verify the domain:

> APIs & Auth Domain verification You need to verify domain ownership to allow webhook notifications to be sent to your external domains. Google verifies that the user owns each of the listed domains via Search Console.

To do that I just have to add an HTML file gave by Google to my webapp root.

I did and I published the app, but the file, also if in the directory, still not accessible and Google can't validate the domain.

I noticed 2 issues:

First of all I had to force the publish of the file, it wasn't published automatically. See below:

7387-untitled.png

How to resolve it?

Second I forced the publishing of the file and I found it in the root as shown below:

7414-capture.png

But still not accessible here: googlef7d31af1ee37b43d.html

I tried to add:

public void Configure(IApplicationBuilder app, IWebHostEnvironment env)
{
app.UseStaticFiles();

.....

}

But it doesn't work anyway and I don't want free access to all static file in the root, I have also the appsettings.json with the db connection strings there.

Thanks.

Azure App Services
Azure App Services
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,324 questions
{count} votes

Accepted answer
  1. Luca Bortolotti 96 Reputation points
    2020-04-15T17:20:27+00:00

    Ok, I solved the problem.

    I was using

    public void Configure(IApplicationBuilder app, IWebHostEnvironment env)   
    {  
       .....  
      
       app.UseStaticFiles();  
      
       .....  
    }  
    

    But my file wasn't under the folder wwwroot, actually I didn't have that folder, so:

    • I added a new folder
    • I named the folder as wwwroot and automatically was recognized as wwwroot and set with the specific icon (see image below)
    • I moved my file inside that folder

    That's it... Sorry, but I'm new on this and I wasn't able to figure out this trivial issue!

    7380-capture.png


1 additional answer

Sort by: Most helpful
  1. Luca Bortolotti 96 Reputation points
    2020-04-14T20:25:36.723+00:00

    I solved the first question: It wasn't published automatically because "Build Action" was automatically set at "none".

    I solved put it as "content", see below.

    Still open the second question!

    7436-capture.png

    No comments