Is Psexec 2.30 buggy - I cannot use it to get a SYSTEM prompt any more? (2.20 is fine)

asked 2021-01-12T13:30:45.127+00:00
Mike Diack 46 Reputation points

I think the newly released Psexec 2.30 has a bug. On Windows 7/10 (but not XP), whenever I now try to run: psexec -i -s cmd.exe to get a SYSTEM command prompt, I see: "No process is on the other end of the pipe." This occurs even if I delete the old psexesvc.exe Psexec 2.20 is fine.

Windows Sysinternals
Windows Sysinternals
A website that offers technical information and advanced system utilities to manage, troubleshoot, and diagnose Windows systems and applications.
840 questions
{count} votes

5 answers

Sort by: Most helpful
  1. answered 2021-01-12T15:52:45.26+00:00

    I am facing issues with 2.3 when I use the -h flag. With 2.2 worked fine! Since yesterday update of the package this issue came up...

    No comments

  2. answered 2021-01-12T16:34:33.743+00:00
    Eric Huggins 1 Reputation point

    I just had the same problem with 2.3.
    Fortunately had a copy of 2.2 handy.
    Deleted psexecsvc using powershell and then ran 2.2.
    Works find now.

    No comments

  3. answered 2021-01-12T19:42:23.427+00:00
    Paul T 1 Reputation point

    I was finally able to get this (psexec.exe -i -s cmd.exe to work by opening the services app on windows 10 as an admin and stopping the service, PSExeSVC. I then tried this psexec.exe -i -s cmd.exe and it worked. Sorry I could not be more help.

    In my post above I was trying to stop the service using PSKill so I am guessing there was an issue with that so I finally had the idea to stop the service by opening the services app as admin and stopping it. Yeah, should have done that from the beginning..

    No comments

  4. answered 2021-01-13T11:29:41.337+00:00
    Alex Mihaiuc 701 Reputation points

    For interactive sessions the -i flag (with no session number) is now necessary.


  5. answered 2021-01-13T14:49:23.04+00:00
    Vafin, Sergei 1 Reputation point

    I got "access denied error" with the version 2.30. With the version 2.2 it worked fine.

    The previous version of pstool 2.45 (with psexec 2.2) can be downloaded from https://www.computerbild.de/?dl=1&dlcid=WjgzVUUuVFpGLlAsTShTLVY5IihbPEZVSi5PKEgsMyhDLFA8RihQWkYuUFFNKFQxVjs2NUY9JiVaPCIoWwouOjNVRC1QJEMtMzBELDM0Si5KR2AKYAo%3D