slawek1481slawek1481-1817 avatar image
0 Votes"
slawek1481slawek1481-1817 asked slawek1481slawek1481-1817 action

WPF - crash with UCEERR_RENDERTHREADFAILED when connected over RDP

We are experiencing a crashes in our WPF application. It occured only when the PC is accessed through RDP.
I am able to reproduce the issue with simple WPF app with TextBlock and StoryBoard only. This application crashes while I'm doing some action in other application.
According to general recommendations in I prepared the minimal solution, full dump and TTD of this issue but where should I upload this things (together it takes around 5 GB of disk space).

My scenarion where the crash occures:
1. Connect to the machine through RDP
2. Start my simple WPF App
3. Start other app and interact with it.
4. In between my simple WPF App crashes with UCEER_RENDERTHREADFAILED (while in background)

I was able to reproduce the issue also on other machines that mine.
I tried to disable HW-Rendering but it doesn't help.`enter code here

My machine on which I am experience the issuse is:

CPU: Core i7-9700K
Windows 10 Pro
VS 2017

This is what WinDbg Preview say at the point of failure (with sxe out command):

MIL FAILURE: Unexpected HRESULT 0xd0000701 in caller: The render thread failed unexpectedly.
00007ff8`ff69ae1b eb04 jmp ntdll!vDbgPrintExWithPrefixInternal+0x239 (00007ff8`ff69ae21)
0:012> k;
# Child-SP RetAddr Call Site
00 000000af`b7c7f320 00007ff8`ff69a560 ntdll!vDbgPrintExWithPrefixInternal+0x233
01 000000af`b7c7f500 00007ff8`bd7d3bbe ntdll!DbgPrintEx+0x30
02 000000af`b7c7f540 00007ff8`bd7d4723 wpfgfx_cor3!MilUnexpectedError+0x4e [F:\workspace_work\1\s\src\Microsoft.DotNet.Wpf\src\WpfGfx\shared\util\UtilLib\debugbreak.cpp @ 191]
03 000000af`b7c7f790 00007ff8`bd7d5130 wpfgfx_cor3!CPartitionManager::ZombifyPartitionAndCompleteProcessing+0x43 [F:\workspace_work\1\s\src\Microsoft.DotNet.Wpf\src\WpfGfx\core\uce\partitionmanager.cpp @ 535]
04 000000af`b7c7f7c0 00007ff8`bd7d4e53 wpfgfx_cor3!CPartitionThread::Run+0x60 [F:\workspace_work\1\s\src\Microsoft.DotNet.Wpf\src\WpfGfx\core\uce\partitionthread.cpp @ 234]
05 000000af`b7c7f7f0 00007ff8`fda87034 wpfgfx_cor3!CPartitionThread::ThreadMain+0x23 [F:\workspace_work\1\s\src\Microsoft.DotNet.Wpf\src\WpfGfx\core\uce\partitionthread.cpp @ 46]
06 000000af`b7c7f820 00007ff8`ff69d0d1 KERNEL32!BaseThreadInitThunk+0x14
07 000000af`b7c7f850 00000000`00000000 ntdll!RtlUserThreadStart+0x21

After that the application crashes with UCEER_RENDERTHREADFAILED

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Did you tried connecting with other computers? What did you do to interact with the app? Please give me more detailed info to reproduce your error.

0 Votes 0 ·

Yes, we tried with other computers. My colleagues run also into this issue. But also only via Remote Desktop.
The other application which I'm interacting with is VECTOR Canape. In this application exists an oscilloscope control which I try to resize. During resizing my Remote Desktop is flashing (the whole remote screen disappears for short amount of time - 0.1s or less). After this action my application crashes. So do also the simple Wpf apllication with only text block and StoryBoard in it.
How should I provide you the sample? Hier I can't event upload the simple solution. The setup for application which I'm interacting with while the crash in my application happens is about 800MB

Do you need also the crash dump and time travel debugging liken mentioned in

0 Votes 0 ·

Please speek to me over private comment. Then I can provide you link to examples.

0 Votes 0 ·

0 Answers