Azure Automation Hybrid Worker can't connect to a local Azure Stack Hub

Dennis Birk 401 Reputation points
2021-01-13T16:03:36.897+00:00

Hello, we use for several tasks Azure Automation with Hybrid Workers.
This works fine for common tasks.
We try now to connect from Azure Automation to a local (disconnected) Azure Stack Hub 2008 with ADFS.

If we run Add-AzEnvironment -Name "AzureStack" -ArmEndpoint $ArmEndpoint, we get the following message from Azure Automation output:
Add-AzEnvironment : An error occurred while sending the request.

With "debug"
Add-AzEnvironment : A command that prompts the user failed because the host program or the command type does not
support user interaction. The host was attempting to request confirmation with the following message: A command that
prompts the user failed because the host program or the command type does not support user interaction. The host was
attempting to request confirmation with the following message: Are you sure you want to perform this action?
Performing the operation "adding environment" on target "AzureStack".

From the Hybrid Worker VM (local) works the cmdlet fine and Add-AzEnvironmet add the new environmet successfully.
But not from Azure Automation.

We found also the following connection error to the Azure Stack Hub endpoint:
From Hybrid Worker VM: We can connect and test with Invoke-WebRequest to the management endpoint.
From Azure Automation: We can't connect with Invoke-WebRequest to the management endpoint.

The question is, where are here the differences?

Azure Stack Hub
Azure Stack Hub
An extension of Azure for running apps in an on-premises environment and delivering Azure services in a datacenter.
180 questions
Azure Automation
Azure Automation
An Azure service that is used to automate, configure, and install updates across hybrid environments.
1,143 questions
{count} votes