Hi ,
I am Ivan, I will help you with this.
Access the Task Manager in the Performance > Memory tab, take a screenshot and post it here.
If you can do a clean install, is that possible?
Independent Advisor - Community
Thanks
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System Specs
CPU - 11th Gen Intel(R) Core(TM) i5-11400F @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
GPU - NVIDIA RTX 3060
RAM - 16GB 3600MHz
Motherboard - ASUS PRIME B560M-A
Problem
I've recently switched from Windows 10 to Windows 11, and I've been experiencing performance issues.
I check the task manager,
IDLE - CPU=3% and RAM=25%
Playing RUST - CPU=60-100% RAM=90-100%
Unreal Engine - CPU=10-60% RAM=60-70%
However often my RAM and CPU will often spike, causing an extreme amount of freezing or crashing. This did not happen on Windows 10.
On the task manager, it showed a large amount of RAM percentage being used, but a significant fraction I could count up from applications on the task manager.
For example, the task manager said "70%" but I could only count 5-8GB, which leaves about 6.2-3.2GB unaccounted for.
After checking Resource Monitor, I discovered that a major amount of RAM was being committed to the system to other applications (Applications and services that I cannot stop due to my system requiring them).
I think the issue may be a memory leak within Windows 11 itself.
What I Have Tried
Almost everything! It feels like.
Updating CPU, GPU, Motherboard, BIOS, and drivers to the latest driver
Uninstalling Armoury Crate (Suspected Possible Memory Leak)
Uninstalling Select Problematic Applications and Reinstalling Them
Tweaking Page File Size on drives
Turning XMP on and off
Overclocking and Underclocking the CPU & RAM
Tweaking FAN Speeds for Temperature issues
Activating and Deactivating Antivirus
Virus Scan
Downloading a different antivirus
Currently, RAM is slowly counting up is at 6.1GB/15.8GB, only have Opera GX open and writing this.
Hi ,
I am Ivan, I will help you with this.
Access the Task Manager in the Performance > Memory tab, take a screenshot and post it here.
If you can do a clean install, is that possible?
Independent Advisor - Community
Thanks
Hello Seth,
Here's a structured breakdown of what might be happening and what else you could try:
Possible Causes
Here's a structured breakdown of what might be happening and what else you could try:
Possible Causes
Additional Steps to Consider
Here are some advanced suggestions that might help:
mdsched.exe
in the Start menu and run the tool to check for faulty RAM.msconfig
to perform a clean boot. This disables all non-Microsoft services and startup items—great for isolating problematic background processes.
Best regards,
Ian | Microsoft Q&A Support Specialist
Hi ,
Did you manage to solve the problem?
Independent Advisor - Community
Thanks