Unable to login in native Teams app since Ubuntu upgrade to 20.04

Marc 6 Reputation points

Used to work fine, but since the upgrade to 20.04, I get:

Foutcode: env_check_error
Kan geen verbinding maken met instellingeneindpunt

(In English: Error code env_check_error, cannot connect to settings endpoint).

apt purged the installation already, removed Microsoft directory in .config and reinstalled, disabled ufw, tried hook.json hack, but no show.

The web client just works.
Log file in the attachment.7596-logs.txt

Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
453 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Marc 6 Reputation points

    Starting teams as root works, so tried to find the difference by stracing /usr/share/teams/teams and found out that firefox libraries libnss3.so, libnssutil3.so, libsmime3.so and libsnpr4.so were loaded instead of the ones in /lib because of a LD_LIBRARY_PATH in my .bashrc. If I remember well, I needed that one for java.

    1 person found this answer helpful.
    0 comments No comments

  2. JimmyYang-MSFT 39,231 Reputation points Microsoft Vendor

    Hi Marc-1336!
    Does this issue only persist in Ubuntu 20.04?
    Does anyone else have the same issue in Ubuntu 20.04?
    It recommends you try to update your client to the newest version and make sure if there is anything which may be prohibiting it after a period of time(antivirus/firewall).

    0 comments No comments

  3. Russell Martin 1 Reputation point

    I have a fresh Ubuntu 20.04 and the teams installer from Microsoft is reporting as 'not supported'. Version both the deb and rpm

    0 comments No comments

  4. Lucas Vieira da Costa 1 Reputation point

    I have been experiencing problems with my new Ubuntu 20 LTS app version, I previous had have this problem since I was using this app on my 18 LTS version... a brief description of this problem is that when I'm logged into a meeting suddenly the app close itself without any interaction made by me, usually I'm just having classes (sadly my University had chosen Meetings for our classes) and I can't explain why and how it usually happens, I'm just watching my classes, how it is difficult to maintain a stable version whose proposal is just to deal the meeting without giving me problem stopping in the middle of my teacher's lesson in every twenty minutes or half an hour ... That's to bad, that why I prefer Google, here my tip: keep Meeting as simple as it possible and navigable by a browser because even your web app version has lack of quality =/

    0 comments No comments