windbg does not show dbgprint messages

DHAIY DHAIY 1 Reputation point

Hi all,

I'm running windbg local kernel debugging. Basically I need to check some DbgPrint messages.

My OS: WIndows server 2019 version 1809

Windbg version: 6.9.0003.113 AMD64

I've run below 2 commands to enable local debug

bcdedit /debug on
bcdedit /dbgsettings local

and Enabled Kd_xxx_Mask as,

lkd> dd nt!Kd_NDIS_Mask L1
fffff80622ada4f8 ffffffff lkd> dd nt!Kd_DEFAULT_Mask L1 fffff80622ada544 ffffffff

Then I ran "!dbgprint". I suppose when I load one net driver, I can see a lot of messages from OS kernel.

but in fact I saw some strange characters.

lkd> !dbgprint

Can someone help here to let me know any steps I did wrong?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,275 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Carl Fan 6,836 Reputation points

    You may have to do below settings in registry to enable the debug prints.

    Open up the registry.
    Go to path, “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Debug Print Filter”. If "Debug Print Filter" is not present then create it.
    Add value “DEFAULT” : REG_DWORD : 0xFFFFFFFF and then reboot.

    after windbg attachment, you could restart, without turning off debugger.
    Hope this helps and please help to accept as Answer if the response is useful.
    Best Regards,

    0 comments No comments

  2. DHAIY DHAIY 1 Reputation point

    Hi Carl,

    I already have that keys created in Registry and verified that by,
    lkd> dd nt!Kd_DEFAULT_Mask L1

    I meant the value of nt!Kd_DEFAULT_Mask follows the value I set in the registry.
    But still I can't see Dbgprint messages from Windebg.

    Note: I'm using windbg local debug, not debugging a remote server.


    0 comments No comments