Configuration of custom domain for an app service

asked 2020-04-29T13:15:03.73+00:00
Maciej Kosarzecki 21 Reputation points

I've got an issue while trying to configure a custom domain for my web app. I followed the MSDN tutorial step by step. I've got a domain foo.com which I'd like to configure for a web app foo-app.azurewebsites.net

I can see that both A and TXT records are set correctly:

Yet, I am still getting an ownership verification error:

{
 "isHostnameAlreadyVerified": false,
 "customDomainVerificationTest": "Failed",
 "customDomainVerificationFailureInfo": {
 "extendedCode": "04006",
 "messageTemplate": "A TXT record pointing from asuid.{0} to {2} was not found. Alternative CNAME record awverify.{0} to awverify.{1} was not found either.",
 "parameters": ["foo.com", "foo-app.azurewebsites.net", "[verificationCode]"],
 "code": "BadRequest",
 "message": "A TXT record pointing from asuid.foo.com to [verificationCode] was not found. Alternative CNAME record awverify.foo.com to awverify.foo-app.azurewebsites.net was not found either."
 },
 "hasConflictOnScaleUnit": false,
 "hasConflictAcrossSubscription": false,
 "txtRecords": ["foo-app.azurewebsites.net", "v=spf1 a mx -all"],
 "aRecords": ["13.69.68.16", "185.11.130.0", "78.47.101.175", "185.170.107.67", "13.69.68.16"],
 "alternateCNameRecords": ["awverify.app-foo-app.azurewebsites.net"]
}

Could you help me with the correct configuration? What am I missing? Why doesn't azure recognize these records?

Azure Web Apps
Azure Web Apps
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,293 questions
No comments
{count} votes

Accepted answer
  1. answered 2020-04-29T20:05:42.107+00:00
    Yutang Lin 86 Reputation points

    There has been an update with the domain verification using a new TXT record which is now updated on the docs. Can you try to update your TXT Record with your domain verification ID? More info on the docs below:

    https://learn.microsoft.com/en-us/azure/app-service/app-service-web-tutorial-custom-domain#get-domain-verification-id


1 additional answer

Sort by: Most helpful
  1. answered 2020-05-14T07:50:11.843+00:00
    Ferdinando Simonetti 1 Reputation point

    Hello,
    I'm just trying to perform a quick test of traffic manager multi-region setup (I'm using ".trafficmanager.net" default domain for T.M. profiles and ".azurewebsites.net" for my "test" webapps).
    I've set up the whole thing partially with Azure CLI, and partially from the portal:

    az group create --name azuremolchapter11 --location eastus
    az network traffic-manager profile create --resource-group azuremolchapter11 --name fsmntmp   --routing-method geographic --unique-dns-name fsmntmp
    az network traffic-manager profile create --resource-group azuremolchapter11 --name fsmntmpeastus     --routing-method priority --unique-dns-name fsmntmpeastus
    az network traffic-manager profile create --resource-group azuremolchapter11 --name fsmntmpwesteurope --routing-method priority --unique-dns-name fsmntmpwesteurope
    az appservice plan create --resource-group azuremolchapter11 --name fsmnaseastus    --location eastus     --sku S1
    az appservice plan create --resource-group azuremolchapter11 --name fsmnaswesteurope --location westeurope --sku S1
    az webapp create --resource-group azuremolchapter11 --name fsmnwaeastus     --plan fsmnaseastus     --deployment-local-git
    az webapp create --resource-group azuremolchapter11 --name fsmnwawesteurope --plan fsmnaswesteurope --deployment-local-git
    

    After that, I've set up the "regional" Traffic Manager profiles adding to them as endpoints (with different priorities) both web apps, and I've added both "regional" T.M. profiles as "nested" to "main" Traffic Manager profile.

    Afterwards, I tried to add the "main" T.M. profile's hostname as an additional hostname to both webapps: the first command executed correctly, while the second failed.

    PS C:\Users\ferdi> az webapp config hostname add --resource-group azuremolchapter11 --webapp-name fsmnwaeastus     --hostname fsmntmp.trafficmanager.net
    {
      "azureResourceName": null,
      "azureResourceType": null,
      "customHostNameDnsRecordType": null,
      "domainId": null,
      "hostNameType": "Verified",
      "id": "/subscriptions/f1fbee51-bbe1-4a48-908f-aa600c39faa8/resourceGroups/azuremolchapter11/providers/Microsoft.Web/sites/fsmnwaeastus/hostNameBindings/fsmntmp.trafficmanager.net",
      "kind": null,
      "location": "East US",
      "name": "fsmnwaeastus/fsmntmp.trafficmanager.net",
      "resourceGroup": "azuremolchapter11",
      "siteName": "fsmnwaeastus",
      "sslState": null,
      "thumbprint": null,
      "type": "Microsoft.Web/sites/hostNameBindings",
      "virtualIp": null
    }
    PS C:\Users\ferdi> az webapp config hostname add --resource-group azuremolchapter11 --webapp-name fsmnwawesteurope --hostname fsmntmp.trafficmanager.net
    A TXT record pointing from asuid.fsmntmp.trafficmanager.net to 32fe016b23f5f348b969ac4d41a022607de1c669bc3a155f9916279ed66f14de was not found. Alternative CNAME record awverify.fsmntmp.trafficmanager.net to awverify.fsmnwawesteurope.azurewebsites.net was not found either.
    

    Of course I can go for a custom (owned) domain setup, but I fear that the same problem will arise.
    What am I doing wrong?

    Thanks in advance!

    No comments