Exchange 2016 Add-in deployment

Sedat Ozdemir 1 Reputation point
2021-02-01T06:29:02.583+00:00

Hi,

When I trying to add a add-in in Exchange 2016 CU7 ECP through the XML file I get an error like below:

error
Method not found: 'Microsoft.Exchange.WebServices.Data.GetClientExtensionResponse Microsoft.Exchange.WebServices.Data.ExchangeService.GetClientExtension(Microsoft.Exchange.WebServices.Data.StringList, Boolean, Boolean, System.String, Microsoft.Exchange.WebServices.Data.StringList, Microsoft.Exchange.WebServices.Data.StringList, Boolean, Boolean)'.

Thanks

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,386 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Eric Yin-MSFT 4,386 Reputation points
    2021-02-02T03:05:58.487+00:00

    Do you have Exchange Web Services Managed API installed on your exchange server? Try to uninstall and reboot.
    CU7 is too old, would you update to latest CU?
    Can you find any related error in Event Log?


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Sedat Ozdemir 1 Reputation point
    2021-02-03T10:24:41.447+00:00

    Hi,

    I don't have "Web Services Managed API" on my server. I installed "Web Services Managed API 2.2" but nothing changed.
    Also there is no releated error log in Event log, I just find information log.

    Current User: 'S-1-5-21-957102307-2811433378-2019603151-500'
    Exchange Control Panel finished an Async web request in the thread 16.
    Command: 'GetList_PreLoad'