ADConnect reinstallation problem

Administrador Sistemas 1 Reputation point

Hi everybody.

Trying to start from scartch, I'd first disabled DirSync with

Set-MsolDirSyncEnabled -EnableDirsync $False

and then uninstalled ADConnect from Add/Remove programs.

My initial setup was with Hash sync and SSO.

Now, when I try to install again, I got an error telling that it's in a pending disabling state. If I check with


it's in a False state.

But PasswordSynchronizationEnabled is in true state.

At Azure portal, I can see that DirSync is not installed but Hash syn is still enabled, and SSO too. No other related is enabled.
Thanks for your help in advance.

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
14,646 questions
{count} votes

7 answers

Sort by: Newest
  1. AmanpreetSingh-MSFT 55,521 Reputation points

    Hi @Administrador Sistemas ,

    As directory synchronization isn't activated or deactivated after 72 hrs, follow these steps, and then contact Microsoft Support:

    Run below PowerShell cmdlets:

    • Connect-MSOLService
    • (Get-MSOLCompanyInformation).DirectorySynchronizationStatus

    If the output is "PendingEnabled" or "PendingDisabled" after the expected enablement time period has passed, this is a known issue with Exchange Online.
    Collect the following information from the Windows PowerShell connection:

    • Context ID: To collect the context ID, type the following cmdlet, and then press Enter:
    • Service instance: To collect the service instance, type the following cmdlet, and then press Enter:


    Please do not forget to "Accept the answer" wherever the information provided helps you to help others in the community.

  2. Rob van den Broek 91 Reputation points

    @Administrador Sistemas

    Yes, you did look at the wrong object.
    It is a known bug at Microsoft.
    After waiting for more that 72h it stills got the same problem. By the way - I made a small script that would sent me a msg when the problem was solved. Maybe you can use it to monitor the state.

    Connect-MsolService -Credential $MyCredential  
        $status = (Get-MsolCompanyInformation).directorysynchronizationstatus  
        Start-Sleep -s 300  
    } while ($status -eq "PendingDisabled")  
    $secpasswd = ConvertTo-SecureString "PASSWORD" -AsPlainText -Force  
    $cred = New-Object System.Management.Automation.PSCredential ("Loginaccount", $secpasswd)  
    Send-MailMessage -SmtpServer '' -Credential $cred -UseSsl -From 'NAME <e-mail>' -To 'NAME <e-mail>' -Subject 'Finished' -Body 'You can start installing again'  

    In my case after 72h the problem was not solved. I needed to create a ticked at Microsoft. The problem then was solved within an hour and the script did sent me a mail.
    They told me it was a known bug.
    I hope this will help you.


  3. Manu Philip 14,541 Reputation points MVP

    Hello @Administrador Sistemas ,

    The steps below can help to resolve the issue:

    Run the PowerShell cmdlets:


    It it shows as "PendingEnabled" or "PendingDisabled" still, follow the below steps. It is a known bug and to report to Microsoft with the details

    Context ID: Type the following cmdlet and enter


    Service instance: Type the following cmdlet and enter


    Please mark as "Accept the answer" if the above helps you. Others with similar issue can follow the solution



    0 comments No comments

  4. Administrador Sistemas 1 Reputation point

    Ok, I was checking the wrong parameter
    (Get-MsolCompanyInformation).directorysynchronizationstatus is still in PendingDisabled status so need to wait more (than 72 hours)

    0 comments No comments

  5. Administrador Sistemas 1 Reputation point

    I've uninstalled last wednesday and today (more than 72 h) when reinstalling got the same error, pending disable, but

    DirectorySynchronizationEnabled : False

    LastDirSyncTime : 20/05/2020 16:43:25

    LastPasswordSyncTime : 20/05/2020 16:45:58

    PasswordSynchronizationEnabled : True

    Need to wait more?

    0 comments No comments