Azure NSG inbound port rules not working

CT91 1 Reputation point
2021-02-10T21:14:00.523+00:00

Hello all,

I have a Windows 10 VM running and trying to set up a game server on it which needs public access on port 2456.

I added an Inbound Port Rule to allow 2456 for any Source, Destination and Protocol on the NSG policy for both Subnet and Network Interface, tried only Network Interface as well. I've added an Inbound rule for TCP and UDP for port 2456 in the Windows Firewall too, for some reason it's still being blocked and can't access the port.

Windows VM doesn't appear to be listening for port 2456 either.

The default RDP rule that was added on creation of VM works fine and tried copying same settings with the 2456 port.

Anyone know what could be causing this?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,307 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
2,189 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. TravisCragg-MSFT 5,676 Reputation points Microsoft Employee
    2021-02-10T23:30:25.357+00:00

    Hello!

    Based upon the port, I assume you are also hosting a Valheim server in Azure. First off, Windows Server will be a better SKU for a dedicated server, but Windows 10 should work just fine.

    Make sure to allow ports 2456 and 2457 for Valheim. Don't forget your outbound rules too! There are no flows for UDP, so you will need to allow the protocols outbound too on both your NSG and OS firewall.

    While the server is running, you should see a listening UDP on port 2457 when you run the following command:

    netstat -a -n
    

    Make sure to install the game and host the server files on a data disk (Not the OS Disk C:/ or Temp Drive D:/), or you will get some lag / delays.

    If you are adding the server via the steam favorites, use port 2457.

    0 comments No comments

  2. Zack Powling 1 Reputation point
    2021-02-11T20:18:59.89+00:00

    I'm currently having a similar issue where my server is showing as running inside SSH, UFW status is set to allow 2456, 2457 and 2456.

    I have created inbound rules for 'Any' for ports 2456, 2457 and 2456 in Azure's networking settings for my VM

    and also an outbound rule for all ports (*)

    Running ./vhserver monitor shows up as working

    0 comments No comments

  3. Info GITL 1 Reputation point
    2021-02-18T08:38:08.873+00:00

    I'v e the same problem, could you fix it?

    0 comments No comments