HELP! with Powershell SetPhysicalPresenceRequest method of the Win32_Tpm class

@RealStruggler 21 Reputation points

Hello Can someone please help me with Enabling TPM using Powershell SetPhysicalPresenceRequest method of the Win32_Tpm class.

I have used below script in SCCM Task Sequence, the Task Sequence seems to execute successfully - but the TPM is still disabled.

$tpm = Get-WmiObject -class Win32_Tpm -namespace root\CIMV2\Security\MicrosoftTpm

Also even tried below one liner:

powershell.exe -command "& {(Get-WMIObject -Namespace root/cimv2/Security/MicrosoftTPM -class Win32_TPM).SetPhysicalPresenceRequest(10)}"

powershell.exe -executionpolicy bypass -command "(Get-WmiObject -Namespace "root\CIMV2\Security\MicrosoftTpm" -Class Win32_TPM).SetPhysicalPresenceRequest(10)"

Tried with SetPhysicalPresenceRequest(6), SetPhysicalPresenceRequest(16) - as well. But the TPM is never enabled.

Can someone please help.

Thank you very much

Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,606 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. AliceYang-MSFT 2,076 Reputation points


    I'm not familiar with enabling TPM in SCCM task sequence but Initialize-Tpm is part of the provisioning process for TPM.

    Please try to initialize TPM before SetPhysicalPresenceRequest. If the issue persists, please let me know.
    How do you guys handle TPM in task sequences?

    Initialize TPM:
    powershell.exe Initialize-Tpm

    Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments