Network workstations fail to communicate with WSUS.

Ivanildo Galvão 1 Reputation point

Guys, greetings to everyone.

I set up a WSUS and created a GPO correctly, so that network stations can get updates through it.
But the stations insist on getting updates on Windows Update on the internet, if I block this access on the firewall, they fail the updates, as if they can't connect to the update source, which is WSUS, but on the WSUS console, I see the stations and all the updates they've got.

Any idea how to solve this?
We need all stations to download updates only on WSUS, not on the internet.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
9,551 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Adam J. Marshall 6,181 Reputation points MVP

    Sounds like dual scan going on

    Also, see:

    as it has a bunch of troubleshooting steps under the client side script.

    0 comments No comments

  2. Rita Hu -MSFT 9,441 Reputation points

    Hi IvanildoGalvo-8865,

    Thanks for your posting on this forum.

    Perhaps we could try to check the default AU Service as the below script. Open the PowerShell as an administrator and then post the below script on the clients:

    $MUSM = New-Object -ComObject "Microsoft.Update.ServiceManager"   
    $MUSM.Services | select Name, IsDefaultAUService   

    Please share with us the result. We could try to apply the below policy on the clients to prevent the clients getting updates from the Internet if the default AU Service is not WSUS/SCCM.

    Please apply the Do not allow update deferral policies to cause scans against Windows Update policy.
    Reference picture:

    Hope the above will be helpful. Please feel free to post on this forum if there are any confuse or questions.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments