The Blend design system is not accessible directly Inside my VS2019

Ian turner 66 Reputation points

I have used WinForms in VS2019 a lot, and am used to its "Design" view for laying my Winforms out, but I am only just getting started with WPF, and could not find out how to access the same View design system in my VS2019. I clicked the View-Designer menu option, but nothing happens. I noticed the Option to Edit in Blend, and am now using that, but it means it opens an entirely new and separate VS2019 instance with Blend running while my original Studio is also still running.

Apart from being somewhat confusing, each seems to have partial access to my projects. For example, I have real problems trying to access MS SQL server in Blend, but it works just fine in the main VS instance.

So my question is, how do I get the Blend functionality to ALSO be inside my main VS instance, which means I will have access to both the full Blend design system AND still have direct access to SQL,. I do have the .Net framework installed in VS2019, which someone suggested may be the problem, and indeed the SQL Client stuff in Blend, but sadly that doesn't work so far, at least for me...

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,072 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Dylan Zhu-MSFT 6,391 Reputation points

    Hi Ianturner,

    The Blend for visual studio has more features which can help you edit your WPF designer better. And you can refer to: Comparison Visual studio and Blend for Visual Studio

    I will have access to both the full Blend design system AND still have direct access to SQL,

    Maybe this document can help you.

    Best Regards, Dylan

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our * *documentation* to enable e-mail notifications if you want to receive the related email notification for this thread.**

    0 comments No comments