PersonalizationDesktopImageStatus failed on 14 clients

Fred Fulford 21 Reputation points

We deploy a new desktop wallpaper and lock screen image every month to to all Windows devices in our estate via a configuration profile called “Win10_Device_Restrictions - V1.1”, using the settings Locked Screen Experience > Locked screen picture URL (Desktop only) and Personalization > Desktop background picture URL (Desktop only).


This works on the vast majority of clients, but is failing on some (around 14). Investigation of these clients shows that Deployment Status of Win10_Device_Restrictions - V1.1 shows failed, and when drilling down it shows that every Setting has succeed except for PersonalizationLockScreenImageStatus and PersonalizationDesktopImageStatus.



All devices are running Windows 10 Enterprise 20H2 and are fully up to date.

Multiple reboots have not forced the wallpaper and lock screen image to update, we have tried making a change to the policy to push it back out but these two settings are still failing for these clients. PersonalizationCSP registry key on failing client devices shows the correct URLs for both images (as defined in the configuration profile) but the DesktopImageStatus and LockScreenImageStatus are both showing a value of 2 (Download or copy in progress)


Have checked permissions,

Microsoft Intune Configuration
Microsoft Intune Configuration
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Configuration: The process of arranging or setting up computer systems, hardware, or software.
1,238 questions
0 comments No comments
{count} votes

6 answers

Sort by: Most helpful
  1. Crystal-MSFT 25,806 Reputation points Microsoft Vendor

    anonymous userFulford-1906, From your description, I know we configured a device configuration policy to set desktop wallpaper and lock screen image. But it is failed. The affected settings are PersonalizationLockScreenImageStatus and PersonalizationDesktopImageStatus. And then you go to the device side to check the registry and find the status is 2 (Download or copy in progress.) Not 1 (Successfully downloaded or copied.). If there's any misunderstanding, feel free to let us know.

    In the registry key, I notice the local path of both images are recorded. Could you go to the path and check if the images are there? And check if the folder permission is different with other working ones?

    If there's any update, feel free to let us know.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

  2. Fred Fulford 21 Reputation points

    Hiya, that is correct. When I check the local path as specified in the registry the image is the one from the previous month.

    Many thanks for your response


  3. Fred Fulford 21 Reputation points

    Hiya, yes I've tried this, the URL is accessible.

  4. Jan Hardenberg 1 Reputation point

    You need to generate a SAS token and copy that into your configuration profile:


    0 comments No comments

  5. Rob Sporcic 1 Reputation point

    Are there any updates on this issue? I've been seeing it for the past few days on a few different devices, and different image urls. I can download the images to a local folder on the device using Invoke-WebRequest -Uri in PowerShell, so it seems like there's no issue downloading the file.