AskeJOlsson avatar image
0 Votes"
AskeJOlsson asked azure-cxp-api edited

Can't create cosmos sql database with shared throughput


After deploying a Cosmos-db sql instance through an arm template I cannot create databases with shared throughput. I get the following error:

 Message: {\"code\":\"Forbidden\",\"message\":\"Message: {\\\"Errors\\\":[\\\"DataBase SharedOffer is Disabled for your account, for further queries please contact support.\\\"]

If I change my provisioning scripts to set throughput on containers instead (not preferred) I will get the following error when creating containers:

 {"code":"Forbidden","message":"Message: {\"Errors\":[\"Reached the pre-approved storage limit for the database 
 account. Please contact Azure support to increase this limit.\"]

Is it something in my subscription I need to tune or some options I've missed?

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I'm guessing this is the 26th container you're creating for this database?

0 Votes 0 ·

Hi, thanks for answering, but it is not the 26th container (ran into that problem a couple of months ago, so that is solved).

I'm mosly unsure whether it is my subscription, I have the CONTRIBUTOR role, but I'm not managing my subscription, so i can't really investigate this.

1 Vote 1 ·

I think this is a quota related issue and cannot be solved by changing your ARM template. Please contact support as they can take a closer look at your Cosmos account.


1 Vote 1 ·

@AskeJOlsson Did this get resolved or are you still working with support to resolve this? If this issue is resolved, can you share the resolution? Thank you!

0 Votes 0 ·

0 Answers