Your credentials didn't work remote desktop

Rahamim Levi 366 Reputation points
2021-02-24T09:52:14.547+00:00

Hi everyone,

I want to upgrade a RDS 2008 R2 that has a remote app to 2019.
I already deployed the server, it has connection broker, publishing and web access roles installed. I also deployed group policy that delegate default and fresh credentials with concatenation enabled.
I also installed a trusted certificate from our root CA server. And, deployed the thumbprint via group policy under computer configuration as well. I also deployed the server as a trusted site and set the option to sign in automatically with current credentials.
When I use MSTSC to connect to the server, It works without credentials window.
When I go to the RDWEB page it signs in using my credentials, and when I open a remote app from RDWEB, it signs in using my credentials.
The only problem is when I want to use remoteapp and desktop connection it always says "your credentials didn't work". If I manually enter domain\username and password it does work.

Any ideas?

Thanks in advance, Rahamim.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,382 questions
{count} votes

1 additional answer

Sort by: Most helpful
  1. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,711 Reputation points Microsoft Vendor
    2021-02-25T03:12:40.263+00:00

    Hi,

    I also deployed group policy that delegate default and fresh credentials with concatenation enabled

    1. So, have you deployed all below group policies?

    Allow delegating default credentials
    Allow delegating saved credentials
    Allow delegating default credentials with NTLM-only server authentication
    Allow delegating saved credentials with NTLM-only server authentication

    1. Please ensure that you have specified correct user group that will access to the remote apps on both collection level and remote apps level.
      71905-image.png
      71780-image.png

    Thanks,
    Eleven

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

    0 comments No comments