question

BabuSureshExternalSelfEmployed-8948 avatar image
0 Votes"
BabuSureshExternalSelfEmployed-8948 asked mickog-6801 answered

Outlook Web Add-in MS-Edge WebView WWAHost Issue

Outlook web add-ins are launched every time in a new process instance of MS-Edge WebView browser (WWAHost.exe) losing the Azure AD Authentication SSO session cookies so that users are repeatedly asked to login

Environment and Application Background:
• An Outlook web add-in featuring an ASP.NET Core website using Azure AD OpenID connect SSO AuthCode flow authentication using ADAL .NET Core library
BEFORE: Azure AD Login SSO Sessions used to work and retain login sessions across multiple add-in launches When we were in Windows 1809 and Outlook client (Microsoft 365 Apps), because it used Internet Explorer 11 browser for launching web add-ins
NOW ISSUE: We recently upgraded to Windows 1909 and Outlook Version 2008 Build 13127 (Microsoft 365 Apps for enterprise), the Azure AD SSO login sessions are not maintained across add-in launches, causing the user to login repeatedly

On analysis, as per the Browsers used by Office Add-ins, Outlook add-ins are now launched using MS Edge WebView embedded browser related to process WWAHost.exe, since it creates new process for WWAHost.exe every time add-in is launched causing the SSO session cookies deleted/not visible across WWAHost.exe process instances, hence users are asked to repeatedly login.

Is there a way to Launch the Outlook add-in in the same process instance of WWAHost.exe? as opposed to different process instance everytime addin is launched?


office-addins-devoffice-js-devoffice-vsto-com-dev
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @BabuSureshExternalSelfEmployed-8948,

Welcome!

Please kindly understand that here we mainly focus on general issues about Outlook desktop client but your issue is more related to your Outlook for Web client and add-ins development. We do know little about that. So, to better solve your issue, I removed the Outlook tag and add some develop-related tags here.

The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thanks for your understanding and hope your question will be resolved soon.

0 Votes 0 ·

ok Jeff, thanks.

0 Votes 0 ·

1 Answer

mickog-6801 avatar image
0 Votes"
mickog-6801 answered

We are having very similar issues with SSO and Windows 10 upgrade. Causing the plugin to open a separate browser for the user to sign in. Wondering did you come to any solution?
Thanks

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.