In xamarin forms ios Launchscreen and App icon didnt change

Alara iscan 6 Reputation points

I changed my App icon from Assets but still didnt change. How can I fix that problem ? I read similar question and I did what they say but it didnt fixed.I also select do not display LaunchScreen and than change it again but id didnt show up still. And my other question is how can I set an image as a Launchscreen without Mac ?


A Microsoft open-source app platform for building Android and iOS apps with .NET and C#.
5,325 questions
0 comments No comments
{count} vote

2 answers

Sort by: Most helpful
  1. Vladimir Pak 6 Reputation points

    If someone still need it. I solved it by following the next steps:

    1. Get any machine running MacOS (it would be easier if you have at least Mac Mini) - install XCode. 1a) IT IS IMPORTANT! Launch a dummy project on XCode. 2). Install Visual Studio 2019 on Mac. 3!!) If you are planning to develop your Xamarin project on PC then you also need to get PC. If not, just use Mac
    2. Install VS 2019 on PC and create Xamarin app. Launch it.
    3. Copy your Xamarin app on Mac and open on Visual Studio
    4. NOW, try to change your icons in Info.plist. (App icon and Loading screen). You must be asked to open the XCode for editing.
    1 person found this answer helpful.
    0 comments No comments

  2. JarvanZhang 23,951 Reputation points


    Welcome to our Microsoft Q&A platform!

    I changed my App icon from Assets but still didnt change.

    After creating AppIcons in the Asset Catalogs folder, we also need to consume the source in Info.plist -> Visual Assets -> App Icons, Source.


    Here is the working screenshot:


    And my other question is how can I set an image as a Launchscreen without Ma

    Try to open the Launchscreen.storyboard with XAML Editor to custom the launch screen.

         <imageView clipsSubviews="YES" userInteractionEnabled="NO" contentMode="scaleAspectFit" horizontalHuggingPriority="251" verticalHuggingPriority="251" id="1315" translatesAutoresizingMaskIntoConstraints="NO" fixedFrame="YES">  
           <rect key="frame" x="71" y="294" width="50" height="195"/>  
           <color key="backgroundColor" colorSpace="calibratedRGB" red="0.95686274509803926" green="0.25490196078431371" blue="0.25490196078431371" alpha="1"/>  

    Best Regards,

    Jarvan Zhang

    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.