Azure VPN Gateway and RRAS - Ping ip fails

Russell Youngs 101 Reputation points
2021-02-26T20:14:13+00:00

Both sides show connected. PS C:\Users\Administrator.STUDY> Test-NetConnection 10.0.0.4 -InformationLevel Detailed WARNING: Ping to 10.0.0.4 failed with status: TimedOut ComputerName : 10.0.0.4 RemoteAddress : 10.0.0.4 NameResolutionResults : 10.0.0.4 InterfaceAlias : Remote Router SourceAddress : 169.254.0.35 NetRoute (NextHop) : 0.0.0.0 PingSucceeded : False PingReplyDetails (RTT) : 0 ms I used the following link as a guide: https://charbelnemnom.com/create-site-to-site-vpn-between-azure-and-windows-rras-server/

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,588 questions
Azure VPN Gateway
Azure VPN Gateway
An Azure service that enables the connection of on-premises networks to Azure through site-to-site virtual private networks.
1,443 questions
{count} votes

Accepted answer
  1. Russell Youngs 101 Reputation points
    2021-03-08T21:05:02.887+00:00

    I ended up getting a second internet connection into my house with a comcast gateway leased router that I turned into bridge mode and connected port 1 to my fortigate 30e. The wan ip address was passed correctly to the fortigate wan port. Configured fortigate with Azure cookbook and setup fw lan to azurephase1. Nat enabled on the lan to wan fw rule for internet browsing to work properly.

    Additionally the virtual networks needed to be peered on azure as well to reach the private addresses. Also removed address space from second virtual network for the peering to work. I recommend a hardware vpn appliance and fortigate support was awesome!

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Russell Youngs 101 Reputation points
    2021-02-27T11:28:51.283+00:00

    I have a netgear comcast router and under Advanced > WAN Setup there is a setting that needed to be checked for the ping to partially work. The setting is called Respond to Ping on Internet Port. Before checked I could only ping as far as the comcast gateway and now I can ping the public ip address that I use as the tunnel ip for on premise.

    I suspect it might be my netgear firewall blocking ping requests. But, it is a tunnel and that should go through.

    0 comments No comments