Limit RDP Connections to one user at a time

Damien471 1 Reputation point

I have a Windows Server 2016 setup without RDS installed.
I am currently able to login with two separate users simultaneously.
In an effort to restrict this I have set RDP Connection Limit to 1 in GP:
Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connection
Number of sessions per user is also set to 1.
I done a gpupdate /force and a full PC restart but two users are still able to connect simultaneously. If I try to log on with a third user I am then prompted that two users are currently active.

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,042 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Manu Philip 14,551 Reputation points MVP

    Hello @Damien471 ,

    Looks like another GPO is blocking it. Use rsop.msc and get all active GPO settings and disable/fine-tune the other GPOs so that this one will work

    Please mark as "Accept the answer" if the above steps helps you. Others with similar issues can also follow the solution as per your suggestion



    1 person found this answer helpful.