Visual Studio 2019, SSIS Script Task Error: The binary code for the script is not found. Build does not help.

Elaena Bakman 31 Reputation points
2021-03-05T19:28:58.25+00:00

I believe this is a bug.

*The first mistake a made was accepting the upgrade from Visual Studio when prompted. This is what I have done:

  1. Opened an existing Script Task on a package that was working and has been built and tested.
  2. Click Edit Script.
  3. Changed nothing and just clicked save.
  4. Get the following error: Scripts contained in the package have compilation errors. Do you want to save changes? (Remember, I changed nothing!)
  5. Open the script back up by clicking on Edit Script again
  6. Go Build and select Build ST_3d9cab1ad210480b84e9145860270c8b

![74910-build-2021-03-05-111513.jpg][1]

  1. The build fails with the following error: Could not find a part of the path 'C:\Users\<User>\AppData\Local\Temp\Vsta\424749ca2d4f4772b6db785f714272fb_out'… ![74933-build-error-2021-03-05-111711.jpg][2]

Other things I have done: I have deleted the script and created a new one. Even if you add no code, and just click save and close it removes the binary code. Clicking build just shows the error that I listed in list item 5 above.

There is nothing that I’ve been able to do to have it recreate or not remove the binary code. I have tried to fix it by uninstalling Visual Studio, uninstalling Microsoft.DataTools.IntegrationServices and every sign of Visual Studio ever existing on my machine through the Control Panel. Reinstalled Visual Studio and the issue is back.

Thanks!

[1]: /api/attachments/74910-build-2021-03-05-111513.jpg?platform=QnA [2]: /api/attachments/74933-build-error-2021-03-05-111711.jpg?platform=QnA

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,862 questions
SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,517 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anthony Green 111 Reputation points
    2021-03-08T17:48:17.107+00:00

    If you have updated to VS 2019 16.9.0 then SSIS is broken for script tasks.

    You need to downgrade to 16.8.6 or below.

    I am in the same issue but I use community so it's not an easy downgrade unless someone knows how.....

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Monalv-MSFT 5,896 Reputation points
    2021-03-08T07:19:32.087+00:00

    Hi @Elaena Bakman ,

    Could you please share the example script in the Script Task?

    Hope the following links will be helpful:
    1.“The binary code for the script is not found”
    This is often caused to to an error or omission in the code in the script task. If you are certain that the code is correct you can go to the script properties and set the PrecompileiIntoBindaryCode to ***False****, the default is set to true. This is under the Properties or in the Script option of the properties window.*

    2.SSIS Error: The binary code for the script is not found

    Best regards,
    Mona


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Floris Jan Galesloot 1 Reputation point
    2021-03-08T17:35:19.007+00:00

    I am having the exact same issue after updating VS 2019 last week. After I saw the issue first, I tried to solve it by installing all updates of the installed extensions, to no avail.
    The code is correct, it worked before the update.

    This also happens in new (empty) projects with a new package by just adding an unmodified script component using the template code.

    Regards,
    Floris Jan