SandqvistJonas-6129 avatar image
0 Votes"
SandqvistJonas-6129 asked TianyuSun-MSFT commented

Is it possible to run vstest.console.exe in sandbox?

I'm trying to run a test executable created in visual studio in the sandbox environment. But running the executable does not give any output in the sandbox environment (have failing tests in the executable).

I have also tried via the wsb file to give the sandbox environment access to "Microsoft Visual Studio\2019\Enterprise" to be able to use vstest.console.exe with testadapterpath set. this gives an error: --list_content=DOT failed with exit code -1073741515... (some dll missing?)

Is there something not installed in the sandbox environment or is vstest.consol.exe not supported?

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @SandqvistJonas-6129 , thank you for taking time to post this issue in Microsoft Q&A forum. Did you install Visual Studio 2019 in your sandbox environment? If you installed, does vstest.console.exe and other related files exist under C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\common7\ide\CommonExtensions\Microsoft\TestWindow in the sandbox environment? Could you please share the vstest.console.exe command line that you used with me to check?

0 Votes 0 ·

I start the sandbox with this config file

<HostFolder>C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise</HostFolder>

and then in powershell I run
C:\Users\WDAGUtilityAccount\Desktop\Enterprise\Common7\IDE\CommonExtensions\Microsoft\TestWindow\vstest.console.exe /TestAdapterPath:"C:\Users\WDAGUtilityAccount\Desktop\Enterprise" .\test.exe

0 Votes 0 ·

Hi @SandqvistJonas-6129 , thank you for your feedback.

Please open developer Command Prompt for VS 2019, cd to the folder where saved the .exe file to be tested and type to use command like vstest.console.exe test.exe to run the test. After that, please let me know if there are some error messages reported. Also, please make sure that this test.exe file is generated from the test project(Unit Test project maybe).

Refer to this screenshot:


0 Votes 0 ·

0 Answers